Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS3 GSdx issues
Using r5082, GSdx11 software renderer, rest default. The codec movies work at first, but they soon don't and a purple spot on the bottom of the codec screen appears. I tried setting the clamping mode to full and that doesn't work either.

Sponsored links

Can someone help me resolve this? MGS3 is just about perfect now that I can play it in software mode at full speed. Just the stupid codec movies would randomly break after a bit of playing. Or am I the only one with this issue because nobody else can play this in software mode?
Ok, so I managed to get MGS3 to run almost perfectly with the software renderer, so now I can finally see the game in all its glory with all the post processing effects and character portraits during the codec moments. Well, unfortunately a new bug popped up. At first, the codec movies play fine, but after a while of playing, the codec movies are blanked out with a purple spot on the bottom of the codec screen. The conversation is still going on, just the codec movie is blank. I tried changing the clamping modes and using the legacy VU recompiler but still no luck. I believe this is a genuine GSdx SW bug. Does anyone know if Gabest is aware of this bug?
Did it work well before? If so, what was the last revision you tried before it got broken?
Does it only happen in software mode? Etc ... etc, also post a gs dump (shift + f8) as it might help.
[Image: nbKSK.jpg]
Tell that to Gabest. He might fix it. GSDX is undergoing serious changes.
I've only tried the latest svn and of course it's a software mode since you cannot see the character portraits/movies in hardware mode.
Yeah I can confirm it works in r5065 so it must be the recent changes to the SW renderer in the new svn's that broke it.
How do I tell him about this bug? MGS3 is so close to perfect in software mode, I really hope he can fix this bug.
Tell him through a bug report or PM Him or just go to Google Code/pcsx2 and post your issue there . Tongue2
Could be a bug in the mpeg decoder, how far is this into the game?
30 minutes are so and you will notice a purple spot appear randomly on the lower right of the codec screen. That's when you know the codec movies are going to be blacked out.

Users browsing this thread: 1 Guest(s)