"MSVCP140_1.dll" error on latest Nightly

I just had to reinstall windows 10 on my laptop (rather, I went from Win11 to Win10 in a factory reset), and after re-downloading the latest nightly for PCSX2, it started throwing a few errors at me and refusing to open. Namely, it keeps asking for "MSVCP140_1.dll" and "MSVCP140_2.dll", because "the code execution cannot proceed" without them. I spent hours last night trying to fix this problem.

The most common advice I found was to download various versions of the Microsoft Visual C++ Redistributable, but none worked - PCSX2 would ask me for at least one of those DLLs (and at the moment, both).
I tried manually downloading the .dll files off of the 'dll-files' website, but those just produced new errors.
I've tried redownloading the nightly multiple times, and even an somewhat older version of the nightly from a backup drive - one that was working fine before I reinstalled Windows - throws up this error.

Any help or advice would be supremely appreciated - thank you!

At time of writing, the latest Stable build does still work on my laptop.

The install at this link - both x86 and x64 - seems to have fixed the problem!

Sponsored links

Read the "required software" part
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)