Mana Khemia Alchemists of Al-Revis
I am fully aware many topics were made about this and i read them through thoroughly, so I apologize beforehand if this upsets the admins.

Prior to finding a solution, i had been running said game on PCSX2 0.9.7. r3876, which to my knowledge is latest. I never compiled or anything of the sort, and it has worked for all the .hack games and tales of the abyss perfectly for me.

The problem with Mana K is after completing the first little bit of game and given the chance to leave the academy, I was presented with the much hated black screen. I tried everything from changing some graphic options, played around with the ee/iop and what not, and nothing. I read on another thread that using PCSX2 0.9.7. r3596 would work, and to my current state of utter happiness, it has worked and im outside of the academy.

My question is what was done to the newer version on the emulator that made the game no longer work, or if there is some sort of patch or changes i need to make to the new one? I am currently using the older version, so whether there is a fix or not for newer one is no big deal. Im just curious as to if anyone else has seen this problem before, and if not, im letting the admins know that the newer version gets black screen and older does not.

If anything else is required, such as console info or anything, just let me know. I apologize once again for bringing this matter to surface once again, and apologize for extremely long post Tongue

Sponsored links

Not a bug report... moved.

There are regressions and progressions all the time in emulators (and pretty much all software I guess Tongue2), as far as I know this bug has already been fixed (again) long after the last beta (currently SVN r4411).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Yeah it's been fixed since Smile Failing that version, the DMA Timing Hack will fix it.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
My apologies for posting in wrong section. And thank you for letting me know, so I assume I should alternate between different revisions of the emulator to see what works best with the game I play?

@refraction, the DMA Timing Hack is a fix for the 3876 version? or a fix for the earlier one? without the fix, the 3596 works perfectly fine. I tried using timing hack on the 3876 for the game and it continued producing the black screen problem.

And I assume since there now is a 4411, the one on the pcsx2 website is not latest? Is it a simple google search for the 4411? or a certain place to get it?
The one on the site is the latest suported beta, anything newer is not encouraged or supported but you can either build it yourself or google for recent PCSX2 builds, but again take in count they're not supported in the forums.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64

Users browsing this thread: 1 Guest(s)