Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mana Khemia I - Off Campus black screen
#1
Hello,

I tried to play Mana Khemia I on the newest PCSX2 version. I got a blackscreen when going off campus. I found some old threads (2009 or so) where the issue seems to be resolved in newer program versions. I tried to play with the settings, with no result. Can anyone help me?

Thank you!
Reply

Sponsored links

#2
You also tried 1.5 ?
https://buildbot.orphis.net/pcsx2/
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#3
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.


Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
Reply
#4
IIRC, There is an automatic hack for this one (dma busy ?)
Reply
#5
It's one of those, I'm not at my PC but it's noted in one of the manual gamefixes tooltips.
Reply
#6
Yes,disabling the "Automatic Gamefixes" makes that game to freeze on black screen when going off campus

If for whatever reason pcsx2 is not enabling the option(posting the emulog will probably say why if that's the case),go to Config=>Emulation Settings=>Uncheck Preset=>go to Game Fixes=>enable manual gamefixes and enable "Ignore DMAC writes when it is busy" and then run the game
Reply
#7
(01-10-2018, 07:15 PM)vsub Wrote: Yes,disabling the "Automatic Gamefixes" makes that game to freeze on black screen when going off campus

If for whatever reason pcsx2 is not enabling the option(posting the emulog will probably say why if that's the case),go to Config=>Emulation Settings=>Uncheck Preset=>go to Game Fixes=>enable manual gamefixes and enable "Ignore DMAC writes when it is busy" and then run the game

Thank you! Fixed it! Biggrin
Reply
#8
What is your game serial ID?
Reply




Users browsing this thread: 1 Guest(s)