Manhunt (EU / PAL) Crane Issue
Hi guys,

This is my first post on this site, I love the Pcsx2 emulator and have revisted many of my favoriute games from perhaps the best system ever using it. I am currently playing through Manhunt, and when I get to the crane section my controller stops responding. I have tried restarting the emulator, but everytime I get to that section of the game my controller doesn't work. Is there something I can do to make it work?

I am playing the game off an Iso of my physical copy which I made myself using Imgburn. I am using Pcsx2 ver 1.0.0, I am using lilypad svn 0.11.0, GSdx 5334 ver 0.1.16. The controller I am using is a wierd 360 controller.

As for the specs for my rig it is a one and a half year old beast that can run the latest Tomb Raider on ultra. If you guys need specifics I can list it, but I have run other ps2 games using this setup on Pcsx2 without issue, and Manhunt played splendidly up until the crane section.

If you need some other info I'll try to give it to you as good as I can, I am sadly not a technical genius and may ask stupid questions on how to get the answersTongue2

Any help will be much appreciated!

Best Regards,


Sponsored links

Quote:I am using Pcsx2 ver 1.0.0,
this is an old and unsupported version. please update.
Quote:As for the specs for my rig it is a one and a half year old beast that can run the latest Tomb Raider on ultra.
never ever compare emulated games with native pc games. it's irrelevant.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

I updated Pcsx2 to version 1.2.1 and tried it again but the problem prevails when I get to the crane section.

I didn't know I couldn't compare, sorry.

Intel i7 3.50 ghz
Nvidia Geforce GTX 690
Windows 8.1
32 gb ram

Do you need to know more about the computer?

Thank you for your help Smile
Have you tried mapping the controls to the keyboard for that scene to exclude problems with your controller?

I just tried that, but with the same result. It is as if the game won't recognize the controller (both xbox 360 wierd and the keyboard) when that scene initiates.

Thanks for the suggestionSmile
Could it be that the game freezes either in a way that the graphics output freezes or the next action of the gameplay (for example a dialog) doesn't start? Or are you running through a field where you wouldn't expect anything?

Can you post the emulog after you were in that scene?

Probably you can try different clamping and rounding modes. None/Nearest normally corresponds to fastest emulation but least compatibility. You can just check the other limit to enhance the compatibility.

That was pretty technical and I'll have to find out how I will get an emulog, and how to change the clamping and rounding modes.

The game doesn't freeze as far as I can tell. When you enter the crane there are some boxes that tell you how to operate the crane and I cannot move the crane, exit the crane or bring up the start menu. But the bad-guy walks towards me shooting and I am taking damage, there is nothing wrong with the sound either.

Thank you for your help!
This can help.

All my researchs about it pointed me for this same direction,this is only one demonstration.
I already heard about the same issues in the computer version and the ps2 game running in the emulator.
(The pc version not have support for joysticks far as i know)

I know you have manhunt 1,but its not so diferent.

And....this about the other question,give more stabilitie for the game,but you can lost some speed.(In the images)

Obs 1-Some games really have some controls issues,but this its is extremely rare
Obs 2-Have you tried using a proper control (created especially for that) a true Pc Joystick?

I'm not saying with absolute certainty that this its a problem of the own game production or even a problem of the own emulator since I'm not to much familiari with this game

Attached Files Thumbnail(s)
emulog.txt is either in your pcsx2 root folder under \logs\ (binary/portable/SVN/Git-version)
or in my documents/pcsx2/logs/ if you used the installer.

rounding and clamping modes are in the emulation settings. Destruidor showed the two relevant pages.

You can try to use another pad plugin as SSSPSX. Even if I think it is not a plugin problem it is worth a try.

You should also just try to reload from the memcard if you are using savestates all the time. Sometimes bugs appear and are saved to the savestate. If you load buggy savestates you will never overcome the problem.

As destruidor said some games have broken controls but there are only a few. And I think all of them are not working correctly from the begging or at least one of the first scenes. Since you seem to be already quite advanced and this occurs only very rare I would not expect such a problem.
I have just started playing this game using PCSX2 1.4.0 and I had this problem. Changing the config settings made no difference at all. But what I did find was this. If you press the "drop magnet" button straight away you get a video of the crane picking up the fridge and then the game plays OK. If you do nothing then you get into a still image of the crane with sound effects of you being shot but without losing health. The game has not crashed or really frozen but you can't do anything at all. Keys and controller do nothing. You can't move. You can't exit the crane. You have to exit the emulator and reload. Pressing the button straight away works on both the first and second crane.

Users browsing this thread: 1 Guest(s)