Maximum number of cheats reached
I recently updated from r5325 to r5612 and came across a new problem. Whenever I do something like hit the turbo switch or switch between SW/HW modes in the PS2's browser PCSX2 tries to load all 170 of my pnaches and gives a ton of errors.

When playing an actual game the cheats seem to load fine and I haven't seen these errors yet. Just thought I'd bring it up in case there's a bigger problem down the line

Attached Files Thumbnail(s)

.txt   emuLog.txt (Size: 136,73 KB / Downloads: 3.729)

Sponsored links

Interesting. Could you please try r5561 and r5562 (or any other builds close enough above/below these revisions), test if it started with r5562?

r5662 adds reading widescreen cheats from the cheats_ws folder, but it might have also affected somehow max number of cheats.

The maximum is 1024 right now, which I guess is quite arbitrary. Are you any close to this number? I think this number is the number of cheat lines and not number of cheat files, so if you have 170 files (really? all of them for one game?), you might still have 1024 cheats if each file has about 6 cheats on average.

Also, could you please post the full log of this run? Maybe it'll tell us more. Thanks.
Thanks, I had a hunch the ws_cheat folder was involved! Indeed there's no problem on r5561, the errors appeared at r5562. Below I've attached an emulog with all sources view enabled, hopefully it helps

And I don't know exactly how many cheats I have, but each pnach is for a different game usually containing about 1-5 cheats (but probably a lot more lines). I'd like to delete pnaches for games I don't own anymore, but I've been putting it off forever since it would be so time consuming

Attached Files
.zip (Size: 28,77 KB / Downloads: 146)
I just looked at the log. This is weird, it seems it loads all the cheat files. Did you use full boot? r5562 also adds multiple-files load by wildcards, and it seems the wildcard match all the cheat files.

I'll try to fix this ASAP. Thanks.

Well, I tried full boot with many cheat files, and it still loads only the correct file[s]. On your log, I can't see the game CRC at all. How exactly are you loading this game? Maybe somehow it has an empty CRC and thus searches *.pnach instead of CRC*.pnach ?

[edit 2]
Oh, sorry, didn't read your initial description good enough. So it only happens at the bios pages. And I can reproduce it too. Will look into it.
Should be fixed in r5614, please verify. Thanks for the report.
I can confirm r5614 fixed it, that was quick Biggrin Thanks for taking the time

Users browsing this thread: 1 Guest(s)