Memory Card Issues (Jak X: Combat Racing)
Hello, this is my first post on the platform. I needed help regarding memory card reading problems.

I had just finished Normal Mode on Jak X: Combat Racing and everything was running smoothly, until I shut my computer off for the night.

When I opened my computer the next day I had to reset all the bios on the emulator due to a tab i had opened in which I failed to save before shutting down my computer. 

After resetting the bios, my save data was no longer present on the memory card. I played for a few hours and then reopened the ISO file, and it was there again.

Now, after the power went out last week, none of my games will recognize any of the Memory Cards. They're all formatted, the BIO browser reads them, Config reads them, I ejected and reinserted the cards, I made new cards and transfered the data from the old ones, I've closed and opened the software numerous times, I've even booted other games (Jak and Daxter, Gran Turismo, etc.) in the hopes it was just my ISO.

So far, none of these fixed the issue and Google's not helping the matter. Does anyone have a fix?

EDIT: I run PCSX2 Version 1.6.0, if that helps.

Sponsored links

It's possible that the save file became corrupted when the power went out. Especially if the file was being accessed at the time. So even though you're copying the save from one memcard to another, some of the save data could be damaged and makes it no longer readable when the game is trying to access it. That's all I can come up with. You've already tried everything else that I would have tried
Windows 11 64 bit OS
Intel Core i7-10700
Geforce RTX 2060 6GB

Users browsing this thread: 2 Guest(s)