Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Memory Card Problem - GTA 3 and Vice City
#1
Hello all,
I've been having a bit of a problem with my memory cards on PCSX2 today and was wondering if anyone could help me.
I have the saves for three games on one of my memory cards (imported with MyMC) - GTA San Andreas, 3 and Vice City. I decided to convert them so I could add them to my main memory card folder, which has about 100 saves in it at this point. The games all recognise the saves when they are on the virtual memory card, and all load and save without any flaws.
However, upon converting the saves to a folder, Vice City and GTA 3 no longer recognise the saves at all - upon starting the game in both of them, a new game begins and the opening cutscene plays (as if there was no save present). Going to the save/load screen, the save is not there at all - not corrupt, just not present, as if the memory card is blank.
San Andreas, however, works fine when converted. I moved the folder into my main memory card folder, and it loads and saves flawlessly. It's just the other two that aren't working, which I find quite strange. Does anyone have any ideas on how to fix this?
I was previously on 1.3.1 experimental GIT build when the problem occurred. I've now updated to the latest stable build (1.4.0) but I'm still having the same problem.
Any help would be very much appreciated!  Smile
Reply

Sponsored links

#2
Interesting...

When you go to the folder after converting, do you actually see the folders for the game there?
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#3
(01-20-2016, 11:18 PM)Ryudo Wrote: Interesting...

When you go to the folder after converting, do you actually see the folders for the game there?

Yes, the folder are all there and they look like this...
   

If you go into the individual folders they all seem fine; here's the one for GTA 3:
   
Reply
#4
Yeah you're right. It's completely ignoring the folder for whatever reason.

I'll make a report on github and let Curtiss know.

[Edit]

Actually, for me it happens with GTA San Andreas as well.

[Image: bandicam 2016-01-20 22-59-12-991.png]

The folder and content are clearly there... but it's just starting a new game for me now. While using the actual Memory Card works fine.



[Edit 2]
https://github.com/PCSX2/pcsx2/issues/1136

Posted the issue.

I think it could be related to the filename possibly. Maybe some characters cause it to end up not being read. Which would technically explain why it sometimes does work, and other times it doesn't. But we'll have to wait for AdmiralCurtiss' response on that.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#5
(01-20-2016, 11:56 PM)Ryudo Wrote: Yeah you're right. It's completely ignoring the folder for whatever reason.

I'll make a report on github and let Curtiss know.

Thanks a lot, much appreciated!  Biggrin
It's really strange that it's happening for you on San Andreas now, too. I'm using the NTSC-U version, which might make a difference?
I've just tried with Vice City Stories and Liberty City Stories as well - they work fine on the memory card, but not in the converted folder, just like the rest.
I've done this with quite a lot of games now, but these are the first I've had any trouble with!
Reply
#6
Using the NTSC-U version as well, so that doesn't seem to be it.

It's indeed strange that San Andreas works fine for you yet here it isn't working... the Memory Card itself does work, but the Folder method won't work on San Andreas for me.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#7
(01-21-2016, 12:10 AM)Ryudo Wrote: Using the NTSC-U version as well, so that doesn't seem to be it.

It's indeed strange that San Andreas works fine for you yet here it isn't working... the Memory Card itself does work, but the Folder method won't work on San Andreas for me.

Just had another try to make sure it was nothing I'd done wrong - tested a few of my others saves; Yakuza, Final Fight Streetwise, FFX, Shadow Hearts 1, 2 and 3, Grandia 2 and 3, and Tekken Tag Tournament - all fine and working in the folder.
Reimported (all GTA saves worked fine on the memory card) and reconverted all the saves again - GTA 3, Vice City, Liberty City Stories and Vice City Stories still do exactly the same thing and start new games, whereas San Andreas works fine. Very odd.
Thanks for your help, again! Do you have any of the GTA games to test?
Reply
#8
Could you upload your unconverted file memory card with the GTA saves so I can compare the converted result with the originals? Thanks.
Reply
#9
(01-21-2016, 12:42 AM)AdmiralCurtiss Wrote: Could you upload your unconverted file memory card with the GTA saves so I can compare the converted result with the originals? Thanks.

Sure, here you are! This contains saves from all the GTA games: 3, Vice City, San Andreas, Liberty City Stories and Vice City Stories.


Attached Files
.zip   SpareCard.zip (Size: 1,32 MB / Downloads: 61)
Reply
#10
For some damn reason GTA San Andreas suddenly works now with loading.

When I uploaded a save for Curtiss on Github (Which labeled as GTA-SA instead of Mcd001) it worked through that one.

So I went and tried my original folder again and now it suddenly works?
This doesn't make ANY sense, as I haven't changed anything.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply




Users browsing this thread: 1 Guest(s)