Mercenaries playground of destruction not running
Ive tried this game on 1.2.1 and 1.3.0

Most games work. But this one does some weird thing where it will get to the main screen then have all vertical lines across my screen and it will litterally fillup with white.Ive even tried playing the game and its just a white screen. Ill include a pic. I have a
i3 3240 3.40ghz
8gb ram
GTX Nvidia 770 4GB

Anything I can do to play it or is it unplayable?

[Image: Mercs_zps1d0a293f.png]

[Image: mercs2_zps63b83946.png]

Sponsored links

You need to use software mode in for that game. Have you tried that? (Can be toggled by F9)
I actually did just a few seconds ago. Holding framerates are really hard on software. even with speedhacks cranked all the way up it still varys between 40-60 fps. It will go down then stay up then go down
You can try to set the extra rendering threads to 1 or 2 (you can also give 3 or 4 a try but I guess 1 is the optimum). This setting can be found in gsdx plugin settings.

Maxing the sliders seldom helps increasing the fps. It can create glitches and wrong fps readings. I would suggest to use only one slider and check step-by-step if it helps or if the fps are saturated. Probably best to start with the EE slider and let VU at minimum. If you found the optimum you can try to set the VU slider (that will cause wrong fps readings) one step higher.

Unfortunately you will not be able to play that game properly without software renderer.
Guess if I really wanna play it I should just buy a ps2 and the game and play it lol. Ill try that tho thx
you're welcome.
and btw, Have a warning for piracy
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)