Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 2 - Audio Glitch
#1
Hello everyone. I'm having trouble with Metal Gear Solid 2: Substance on the PCSX2 emulator. I've tried two different copies of the game and the issue persists. My issue is with the audio crackling and lagging. I have recorded some game play so that the issue is more clearly understood. For the clearest representation of the problem, you may skip to 00:30.

VIDEO LINK: https://www.youtube.com/watch?v=1RpqGo0B...e=youtu.be

Here are my comp specs:

CPU: i4770k Haswell 3.5GHz
GPU: Nvidia GeForce GTX 780Ti 3GB
RAM: 16GB
MB: Asus Maximus VI Hero

There should be absolutely zero problems running the emulator/game on my PC, so I am inclined to think that the issue is in configuration (which I am admittedly unclear on) or the emulator/game itself.

Any help is sincerely appreciated. Thanks all!
Reply

Sponsored links

#2
I know this tanker part is particularly demanding.
what do the EE% & GS% say when you get thos lag/crackles ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Thanks for the quick reply, jesalvein! The EE% hovers between 60-80% but quickly settles down to between 65-70% after spiking to 80 and the GS% never really goes above 40%-ish.
Reply
#4
that's quite high and could explain the slight lagging.
tried using speedhacks, especially MTVU hack ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
I have not tried speedhacks yet. I'll give that a go and reply back here to let you know how it goes. Thanks for the suggestion.
Reply
#6
Regardless of overall speed, you can fix the sound issue by:

Config->Audio->plugin settings->Change "Timestretch" to "Async mix"
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#7
Blyss, you're wonderful <3 That totally fixed the issue. Thank you both for your help and suggestions. I am thrilled to be able to play this game now without cringing every 10 seconds. So am I correct in thinking that this was not an issue of speed? I would think that my system is OP to run this kind of thing.
Reply
#8
I'd tend to think it's a lack of power in your system.
while it's a very good one, it can be a bit limited for some games.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
PCSX2 is special as far as system requirements. It WAS an issue of speed. The settings I gave you allow the audio to run independently of the video. So even if video slows down, the audio does not. And hence it does not crack, pop, or whatever.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#10
Awesome, thanks for the explanation. This is an incredibly demanding program then it seems. Either way, glad to have it fixed! Now, time to get reacquainted with Solid Snake.
Reply




Users browsing this thread: 1 Guest(s)