Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 2 and 3
#1
I can play MGS 3 fine without any problems, no lag, no audio problems, cutscenes are fine, 60 fps at all times, but when I try to play Metal Gear Solid 2 the game is laggy and it freezes the audio is extremely choppy and my fps drops to about 15. I don't really know why this could be happening so if anyone could help me out that'd be great.

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#3
I'm using Nvidia gefroce gt 610, AMD fx 4100 quad core processor, 8 gb ram, Windows 8. I'm using PCSX2 1.2.1, also all default settings. I'm trying to play metal gear solid 2 Sons of liberty ISO. It doesn't make sense that MGS 3 will run fine but MGS 2 won't.
#4
Your machine is really too weak for a demanding game like MGS. What do the EE and GS% say in the GSdx window when you get slowdown?
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#5
(08-24-2014, 02:39 AM)xQuincyx Wrote: I'm using Nvidia gefroce gt 610, AMD fx 4100 quad core processor, 8 gb ram, Windows 8. I'm using PCSX2 1.2.1, also all default settings. I'm trying to play metal gear solid 2 Sons of liberty ISO. It doesn't make sense that MGS 3 will run fine but MGS 2 won't.

Each game is different demand just cause one game work fine dont mean another will run too, this goes for MGS games to.
#6
EE is around 55-70 and GS% is 30-35.
#7
Have you enabled the MTVU speedhack? If not, try. It should give you a good boost on your system.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#8
I have tried it but it doesn't change what's happening. The game just has fps lag and audio is laggy and terrible.
#9
Try setting EE cycle rate hack slider to 2 and VU stealing slider to 1. If that doesn't fix it, you either have to give up and play on your PS2, over overclock your CPU to around 4.5Ghz.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#10
Still really concerned as to why the third games works with no issue but the second game won't.




Users browsing this thread: 1 Guest(s)