Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 3 Subsistence fps drops
#1
Normally during gameplay the game runs on 60 fps, but sometimes during cutscenes especially in the ones with heavy use of lighting there are fps drops. There is also fps drops in the Groznyj Grad Runway bike chase scene(Gameplay). Can someone help me to  run the game with consistent 60 fps. I have till now only used the preset settings on 3 and 2.

Here are my specs:
CPU: intel i7-9750H 2.60Ghz
GPU: nvidia geforce gtx 1660ti
Ram:8GB DDR4

BTW I am using Direct3D 11(Hardware)
Reply

Sponsored links

#2
(10-06-2020, 07:43 AM)MistWolf Wrote: Normally during gameplay the game runs on 60 fps, but sometimes during cutscenes especially in the ones with heavy use of lighting there are fps drops. There is also fps drops in the Groznyj Grad Runway bike chase scene(Gameplay). Can someone help me to  run the game with consistent 60 fps. I have till now only used the preset settings on 3 and 2.

Here are my specs:
CPU: intel i7-9750H 2.60Ghz
GPU: nvidia geforce gtx 1660ti
Ram:8GB DDR4

BTW I am using Direct3D 11(Hardware)

Make sure your system power plan is high performance, and what are your gsdx settings?
Reply
#3
(10-06-2020, 07:48 AM)SeyedAli Wrote: Make sure your system power plan is high performance, and what are your gsdx settings?

It's 
Render: DIRECT3D 11 Hardware
Adapter: Nvidia Geforce GTX 1660ti
interlacing: none
texture filtering: Bilinear
Hardware rendering settings are all on default and Anistropic filtering is off
I have tried it with power plan with performance but it ends up heating up my laptop without producing much results.
Reply
#4
(10-06-2020, 07:57 AM)MistWolf Wrote: It's 
Render: DIRECT3D 11 Hardware
Adapter: Nvidia Geforce GTX 1660ti
interlacing: none
texture filtering: Bilinear
Hardware rendering settings are all on default and Anistropic filtering is off
I have tried it with power plan with performance but it ends up heating up my laptop without producing much results.

Better if you take a screen shot of it, or post your gsfx settings(in a code tag)
Reply
#5
SeyedAli
Better if you take a screen shot of it, or post your gsfx settings(in a code tag)

   
Reply
#6
consistent 60 fps all the time on this game cannot be achieved for now. if you really want this, play it on your real PS2.
That said, i'd suggest you give ogl renderer a try since you have a pretty good nvidia GPU
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(10-06-2020, 08:13 AM)MistWolf Wrote: SeyedAli
Better if you take a screen shot of it, or post your gsfx settings(in a code tag)
You can try opengl too but if didn't work, return to Direct 3D Hardware and try following settings:
Interlacing: Automatic
CRC hack level: Full
Enable HW hacks, go to advanced settings and hacks, mark "disable depth emulation(may cause glitchs, if did, untick it), try skipdraw range.
If you have a cpu with more than 3 physical cores, this will be helpful:
Open the emulator, Config, Emulation settings, speedhacks, mark MTUV and see the result.
Reply
#8
(10-06-2020, 08:21 AM)jesalvein Wrote: consistent 60 fps all the time on this game cannot be achieved for now. if you really want this, play it on your real PS2.
That said, i'd suggest you give ogl renderer a try since you have a pretty good nvidia GPU

Yeah I was aware of that actually... The fps drops during cutscenes didn't bother me actually but the gameplay started to have fps drops in areas where it didn't happen before( this was actually my 3rd playthrough), so this was what actually started to concern me, let me try it with openGl. Also I just wanted to ask what is actually better openGl or direct3d, and are games like really mgs3(also shadow of colossus) really hard to emulate, what about games like kingdom hearts and silent hill 2? I know this isn't the right thread to ask but I am a bit new to ps2 emulation and I have heard the compatibilty reports in pcsx2 wiki are a bit outdated so I just wanted to ask.

Thanks for Helping,
Cheers!!

(10-06-2020, 08:27 AM)SeyedAli Wrote: You can try opengl too but if didn't work, return to Direct 3D Hardware and try following settings:
Interlacing: Automatic
CRC hack level: Full
Enable HW hacks, go to advanced settings and hacks, mark "disable depth emulation(may cause glitchs, if did, untick it), try skipdraw range.
If you have a cpu with more than 3 physical cores, this will be helpful:
Open the emulator, Config, Emulation settings, speedhacks, mark MTUV and see the result.

I will try it, thanks man!!
Reply
#9
(10-06-2020, 08:32 AM)MistWolf Wrote: Yeah I was aware of that actually... The fps drops during cutscenes didn't bother me actually but the gameplay started to have fps drops in areas where it didn't happen before( this was actually my 3rd playthrough), so this was what actually started to concern me, let me try it with openGl. Also I just wanted to ask what is actually better openGl or direct3d, and are games like really mgs3(also shadow of colossus) really hard to emulate, what about games like kingdom hearts and silent hill 2? I know this isn't the right thread to ask but I am a bit new to ps2 emulation and I have heard the compatibilty reports in pcsx2 wiki are a bit outdated so I just wanted to ask.

Kingdom hearts : should be fine.
sh2 : can't tell, I never tried it

Best would be to pop your DVD in your PC and give try to see
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)