Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Microstutter when in fullspeed?
#1
My PC is powerful enough for the games I Play, and all of them play at full speed without speed hacks (For God of War 1 and 2, and MGS3 I use only the MTVU Speed hack, and nothing more), but every now and then, even though I'm at full speed, I suffer from micro stutter (even if nothing happens on screen). It happens in every single game I have

MY PC: Windows 10 64Bit Anniversary update build 1607, [email protected] (I know that PCSX2 Doesn't benefit from More than 4 CPU Cores, and that's why every time I launch the app  I limit the affinity to only 4 Physical cores), GTX 1080 and 16GB Ram.

Things I tried: Turning on and off Vsync in the GS settings, Enabling and disabling the MTVU Hack for each game, "Overclocking" the EE in emulation settings and then lower it back to normal speed, turning on and off Vsync in the Nvidia control panel. unfortunately, nothing helps me, and I still get stutters from time to time. Even disabling Hyper Threading in the BIOS and Limit my PC to 4 Cores instead of 6. Playing in full screen mode doesn't help, with or without Vsync. 

It happens on D3D9, D3D11 and OpenGL backends, and I tried stable version 1.4.0 and multiple 1.5.0 Development versions, including the latest 10. All of my games are NTSC if that matters. I play games like DMC 1 and 3SE, Okami, God Hand, MGS2 and 3, God of War 1 and 2, Ratchet and Clank series, Sly series if that matters.

Is there any solution to this?
Reply

Sponsored links

#2
(05-26-2017, 08:18 PM)Assassin47 Wrote: My PC is powerful enough for the games I Play, and all of them play at full speed without speed hacks (For God of War 1 and 2, and MGS3 I use only the MTVU Speed hack, and nothing more), but every now and then, even though I'm at full speed, I suffer from micro stutter (even if nothing happens on screen). It happens in every single game I have

MY PC: Windows 10 64Bit Anniversary update build 1607, [email protected] (I know that PCSX2 Doesn't benefit from More than 4 CPU Cores, and that's why every time I launch the app  I limit the affinity to only 4 Physical cores), GTX 1080 and 16GB Ram.

Things I tried: Turning on and off Vsync in the GS settings, Enabling and disabling the MTVU Hack for each game, "Overclocking" the EE in emulation settings and then lower it back to normal speed, turning on and off Vsync in the Nvidia control panel. unfortunately, nothing helps me, and I still get stutters from time to time. Even disabling Hyper Threading in the BIOS and Limit my PC to 4 Cores instead of 6. Playing in full screen mode doesn't help, with or without Vsync. 

It happens on D3D9, D3D11 and OpenGL backends, and I tried stable version 1.4.0 and multiple 1.5.0 Development versions, including the latest 10. All of my games are NTSC if that matters. I play games like DMC 1 and 3SE, Okami, God Hand, MGS2 and 3, God of War 1 and 2, Ratchet and Clank series, Sly series if that matters.

Is there any solution to this?
You are not alone. This is a real issue. I don't care what the devs say. This issue only occurs when using opengl. D3d11 and 9 don't have this issue. It sucks because opengl is the most accurate plugin. I have 4 different system in my home. Every single system is more than enough to run games at full speed, but with opengl full speed still exhibits micro stutter or some kind of frame pacing issue. Only thing that reduces this is a 144hz monitor. Even then there is still some kind of frame pacing issue. I fear this will never be resolved because it's been an issue for years. The devs will continue to ignore. Or they're just blind. My specs:


Cpu:7700k @5ghz (passed 30hrs of prime95)
Gpu: GTX 980
Ram: 32gb DDR4 3000mhz
Reply
#3
(05-27-2017, 12:06 AM)Old$ch00LGamer Wrote: You are not alone. This is a real issue. I don't care what the devs say. This issue only occurs when using opengl. D3d11 and 9 don't have this issue. It sucks because opengl is the most accurate plugin. I have 4 different system in my home. Every single system is more than enough to run games at full speed, but with opengl full speed still exhibits micro stutter or some kind of frame pacing issue. Only thing that reduces this is a 144hz monitor. Even then there is still some kind of frame pacing issue. I fear this will never be resolved because it's been an issue for years. The devs will continue to ignore. Or they're just blind. My specs:


Cpu:7700k @5ghz (passed 30hrs of prime95)
Gpu: GTX 980
Ram: 32gb DDR4 3000mhz

Well, I t actually happens on D3D9 and 11 too. And damn, jealous of that 7700K OC of you Smile
Reply
#4
Thats strange, you are positive it does it on d3d as well? Every system I've tested this wasn't true. Only opengl has ever done this. You using the latest dev build? That OC wasn't easy. Takes 1.425v to run. Not easy to cool at that voltage had to delid and lap the processor. I'm using liquid metal and an H115i. @4.9 it only requires 1.36v.
Reply
#5
(05-27-2017, 12:11 AM)Assassin47 Wrote: Well, I t actually happens on D3D9 and 11 too. And damn, jealous of that 7700K OC of you Smile

that cause probably not cause DX9/11 or Opengl only, stutter can come from lots sources ,
Could be from
vsync
hdd ( issue or fragmentation)
Windows Aero
Graphics Drivers
the game it self
Sound drivers
system latency issue
incompatibility between all this

The list goes on Hell if the original game on the ps2 had micro stuters pcsx2 will most likely reproduce them, same for frame rate issue if game on ps2 had them too.
Reply
#6
I'm not sure this is a common issue, otherwise you'd probably see a lot more posts reporting it. I use OpenGL, with 5x IR with most my games and they play fine. I haven't noticed any micro-stutters. Even after playing a couple games for about an hour, they all seem to play smoothly. I use the latest 1.5 GIT's. Make sure your PC is set to high performance & if using a NVidia GPU, set the 3D Settings to Prefer Maximum Performance. But as tsunami2311, it can be caused by a lot of different factors. The HDD is another thing that would be on the top of my list to check out
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
16 GB DDR4 RAM
Reply
#7
(05-27-2017, 12:26 AM)envisaged0ne Wrote: I'm not sure this is a common issue, otherwise you'd probably see a lot more posts reporting it.  I use OpenGL, with 5x IR with most my games and they play fine.  I haven't noticed any micro-stutters.  Even after playing a couple games for about an hour, they all seem to play smoothly.  I use the latest 1.5 GIT's.  Make sure your PC is set to high performance & if using a NVidia GPU, set the 3D Settings to Prefer Maximum Performance.  But as tsunami2311, it can be caused by a lot of different factors.  The HDD is another thing that would be on the top of my list to check out

its not, might be more noticed able on 120+ hz monitors though
Reply
#8
(05-27-2017, 12:32 AM)tsunami2311 Wrote: its not, might be more noticed able on 120+ hz monitors though

Well i can tell you I've nearly driven myself mad trying to solve this over the years. I've compared games running on pcsx2 to the original ps2, I've tried 3 different types of storage, tried Windows 7, 8, 10, tried vsync on/off, limiting frame rate with seperate program, tried different refresh rates, tried all kind of different builds, tested multiple systems, and the list goes on. I think you get the point. I've probably tested this more than anyone because it drves me insane lol. If i had more knowledge with programming i swear i would find the cause. It's what keeps me from enjoying the emulator fully. None of the games i tested on pcsx2 displayed micro stutter on real hardware. I just wish this could be looked into a little more.
Reply
#9
Thanks for the answers, I think that My PC is fine, Dolphin works perfectly fine and without stutters on my PC (Excluding shader generation stutters of course), and Regular PC games also work without issues on My PC, and they are installed on my HDD. I also tried running my games from my SSD, and there was no difference whatsoever. Is there any way to disable Windows Aero on windows 10?

Old$ch00LGamer I tried again using D3D11, and I think you are right, as Devil May Cry 1 doesn't stutter any more. It did stutter in OpenGL However. I need to test it further and with other games too.

I really hope that the developers will find a solution as I found other threads about it, or at least add an Exclusive fullscreen option.

Edit: Also tested Ratchet and Clank in D3D11, and yeah, it was silky smooth at fullspeed, got no stutter at all. Maybe it's indeed an issue with OpenGL only.
Reply
#10
(05-27-2017, 12:37 AM)Assassin47 Wrote: Thanks for the answers, I think that My PC is fine, Dolphin works perfectly fine and without stutters on my PC (Excluding shader generation stutters of course), and Regular PC games also work without issues on My PC, and they are installed on my HDD. I also tried running my games from my SSD, and there was no difference whatsoever. Is there any way to disable Windows Aero on windows 10?

Old$ch00LGamer I tried again using D3D11, and I think you are right, as Devil May Cry 1 doesn't stutter any more. It did stutter in OpenGL However. I need to test it further and with other games too.

I really hope that the developers will find a solution as I found other threads about it, or at least add an Exclusive fullscreen option.
Yeah trust me don't listen to these guys the stutter is there and is opengl only. The only thing left i can think of testing is linux. Also want to note that pcsx2 is not the only emulator to do this. Some emulators that use opengl have the same problem some do not.
Reply




Users browsing this thread: 1 Guest(s)