Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Minimum Requirements - The Future
#1
The minimum requirements aren't just about putting down an arbitrary system requirements to run a system. It should reflect the minimum that that PCSX2 is compiled against.

Currently the system requirements are:

System Requirements
 



Quote:Minimum (most games will be unplayable slow)
  • OS: Windows Vista SP2 or newer or GNU/Linux (32-bit or 64-bit)

  • CPU: Any that supports SSE2 (Pentium 4 and up, Athlon64 and up) @ 1600 STR or better

  • GPU: DirectX 10 GPU or better

  • RAM: 2GB or more
Recommended
  • OS: Windows 7/8/8.1/10 (64-bit) or GNU/Linux (64-bit)

  • CPU: Intel Haswell 4xxx series (or AMD equivalent) @ 2000 STR or better

  • GPU: DirectX 11 GPU or greater

  • RAM: 4GB or more




windows vista is no longer supported. Pentium 4 and Athlon64 are hopelessly under powered and almost no one uses these systems anyway.

On the recommended system requirements Windows 7 is no longer going to be supported by microsoft in less than 6 months from now and support for Windows 8.0 has already ended.


I'm going to put forth a new minimum.

Quote:Minimum
  • OS: Windows 8.1/10 (64-bit) or GNU/Linux (64-bit)


  • CPU: Intel Haswell 4xxx series (or AMD equivalent) @ 2000 STR or better


  • GPU: DirectX 11 GPU or greater


  • RAM: 4GB or more
this will allow the new default compile to AVX2 with 64bit, reduce the amount of support required, and focus PCSX2 on the future.
Reply

Sponsored links

#2
p4 and athlon64 including athlon x2 is still runnable as minimum on pcsx2 but requires pixel shader 4 video cards.....
very little games to run below the 1600 STR number.
harvest moon-STH for example
Main PC1:i5-4670,HD7770(Active!)
Main PC2:i5-11600K,GTX1660Ti(Active!)
PCSX2 Discord server IGN:smartstrike
PCSX2 version uses:Custom compiled build 1.7.0 64-bit(to be update regularly)
Reply
#3
(06-24-2019, 01:21 AM)smartstrike Wrote: p4 and athlon64 including athlon x2 is still runnable as minimum on pcsx2 but requires pixel shader 4 video cards.....
very little games to run below the 1600 STR number.
harvest moon-STH for example
4th gen intel processors are 2013/2014 that's plenty old enough to be a minimum. furthermore it's not like the old versions will disappear. they will still be around and work... but i'm suggesting all new versions be compiled to this new minimum.
Reply
#4
I guess i'd like to hear from other users if they can meet my suggested minimum requirements or not.
Reply
#5
they probrably they using unofficial builds like extrenum.
Main PC1:i5-4670,HD7770(Active!)
Main PC2:i5-11600K,GTX1660Ti(Active!)
PCSX2 Discord server IGN:smartstrike
PCSX2 version uses:Custom compiled build 1.7.0 64-bit(to be update regularly)
Reply
#6
I like a Minimum of 1800 str.. and I've run it on several procs that were in the 1800-1850 stp range. Shoot, I'm playing through Kingdom Hearts II right now on a laptop that only has 1800 str and its been rock stable (I've had exactly 2 slowdowns.. both during fmv.. none during game play.

As for graphics.. DX 11 or better I like.. I tend to recommend a gtx 750 or better or an amd rx570 or better for amd (ogl and dx respectively)
amd tr 1950x                                                amd ryzen 5 2500u
asrock x399 taichi                                          amd vega 8 
XFX Radeon rx570                                         16gb ddr 4 2400 ram
32gb gskill ddr4-3200                                    256gb nvme ssd
Windows 10 Pro                                            480gb sata ssd
Custom loop water cooled                               HP envy x360
nzxt 340 case
Reply
#7
Just because MS will stop the support for Win7,that doesn't mean pcsx2 requires at least Win8 which as you said has no support from MS already

I can run plenty of games on my i7-6700HQ at half speed of the cpu or lower depending on the game(some games run at full speed even when I set it at 800Mhz)
I have been using WinXP from 2006 till 2014 and some games were working fine on my ancient Pentium 4 2.8Ghz(I clear Ar Tonelico 1 on it at full speed most of the time)

For the minimum...well that depends on the games you want to play.If I only play NISA\GUST games,I definitely don't need at least 2000stp cpu
If you are getting twice the normal speed at 1800stp,that should tell you that the game definitely don't need a cpu at 1800stp

I can run VP2 at full speed all the time and when I disable the fps limit,the speed can go even 3 times the normal speed(depending on the location)

If pcsx2 drops the support for specific os,only then that os will not be the minimum

For recommended,1600stp is still fine because it covers a lot of games.
Reply
#8
(06-24-2019, 01:43 AM)Seta-San Wrote: 4th gen intel processors are 2013/2014 that's plenty old enough to be a minimum. furthermore it's not like the old versions will disappear. they will still be around and work... but i'm suggesting all new versions be compiled to this new minimum.

Certain 3rd gen. Intel processors should still suffice. I can still play GT4 and GT3 in the latest dev build with minor issues on an i5-3330 and its STP is above 1600. Maybe even older generations can still be used with PCSX2.
PC Specs:
PC: HP Omen 15 dc-0051nr laptop
CPU: Intel i7-8750H (2.2 GHz up to 4.1 GHz)
RAM: 16 GB
GPU: Nvidia GeForce GTX 1060 Notebook (6 GB)
OS: Windows 10 Pro (64 bit)/Windows 8.1 Pro (64 bit)
Storage: 256 SSD PCi NV M.2+1 TB HDD
Need the latest GIT/development build? Click here!
Reply
#9
Gtg, I had a i3 3220 or was it a 3240? That was about an 1800 stp and played many games just fine. My i7 3770, which is still chugging along, handled shadow of the Colossus... Even the 2nd gen 2600 would still handle a lot of pcsx2 games.
amd tr 1950x                                                amd ryzen 5 2500u
asrock x399 taichi                                          amd vega 8 
XFX Radeon rx570                                         16gb ddr 4 2400 ram
32gb gskill ddr4-3200                                    256gb nvme ssd
Windows 10 Pro                                            480gb sata ssd
Custom loop water cooled                               HP envy x360
nzxt 340 case
Reply
#10
(06-24-2019, 11:18 PM)scythefwd Wrote: Gtg, I had a i3 3220 or was it a 3240?  That was about an 1800 stp and played many games just fine.  My i7 3770, which is still chugging along, handled shadow of the Colossus...  Even the 2nd gen 2600 would still handle a lot of pcsx2 games.


then how do you feel about making 64bit processors with SSE4 the new bottom? That would be the Core 2 https://en.wikipedia.org/wiki/Penryn_(mi...hitecture)
It's over 10 years old. then cut out 32 bit support and cut support for windows OSs that Microsoft no longer supports?
Reply




Users browsing this thread: 1 Guest(s)