Minor annoying problems with Persona 4
Let's see, I just downloaded PCSX2 yesterday and was playing Persona 4 'till really late. It worked almost perfectly (way better then I was expecting lol) but something is up with the BG music. about 75% of the time it's slowed down. Like for some reason something is telling the BG music to play at half speed. While the other 25% of the time it's normal. (not sure but I think it's normal in certain areas and not just randomly becomes normal) I tried my best to just ignore it but I just can't and it's really annoying. Especially during battles.

I have everything set to default because I really have no idea what anything does. If you all might need my hardware specs then well Idk to get them Tongue (Even though I think I've been told how before). Anyways it's on windows 7.

Also I know it might be the .iso that is the problem but if it's that then I'm screwed with fixing this problem lol.

Btw I forgot to mention I did experience slowdown once but thats only when I fought five beetle monsters at once. I never had slowdown other then that time so far.

Thanks in advance for your guys' help ^_^

Sponsored links

Are you using any speed hacks? Paste here what the console prints after you run the game, that will pretty much tell us your PC specs
[Image: newsig.jpg]
Now I see where it is. Then again I didn't pay attention to the console. Here is it is:

Quote:PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition (build 7600), 64-bit
Physical RAM = 4094 MB
CPU name = AMD Phenom™ II X4 955 Processor
Vendor/Model = AuthenticAMD (stepping 02)
CPU speed = 3.213 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 00802009
x86EFlags = efd3fbff

x86 Features Detected:
MMX2 .. 3DNOW .. 3DNOW2.. SSE4a

And no I haven't used any speed hacks. I thought about it but I didn't wanna mess with something that Idk what it does exactly.
Yeah I told you to post it after you had booted the game, so we could also see what graphics card you have Tongue
[Image: newsig.jpg]
Quote:Reserving memory for recompilers...

Loading plugins...
Binding GS : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 6.1.7600
ATI Radeon HD 5700 Series (
Binding PAD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 229ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Windows 6.1.7600
ATI Radeon HD 5700 Series (
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\Ryan\Downloads\Shin_Megami_Tensei_Persona_4_NTSC_PS2DVD-STRiKE.[www.usabit.com]\st-smtp4.iso
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2151344 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Ryan\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Ryan\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
GIFTAG warning, size exceeded VU memory size 400
GIFTAG warning, size exceeded VU memory size 400
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_217.82;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_217.82;1) Game CRC = 0xDEDC3B71, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_217.82;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(GameDB) Enabled Gamefix: VuClipFlagHack
EE/iR5900-32 Recompiler Reset
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_217.82;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_217.82;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(R5900) Re-executed ELF Entry point (ignored) [addr=0x00100008]

Ok booted up again to make sure it's right and just pasted everything after what I just posted.
OK your PC should not have any problems emulating this game...what internal resolution/scaling have you set in GSDX (scaling part)? When you get the slowdowns what do the EE and GS percentages on the top of the window display?
[Image: newsig.jpg]
Idk what you mean with the GSDX part. And let me get to the part where it slows down.

EE: 98-100% GS: 10-15%

When it's not slowed down the EE is usually around 20-50% and GS is between 5% and 12%
Looks like your cpu is holding you back at those parts. It's either turn on more speedhacks or overclock the cpu to get rid of that.
I have no idea how to overclock so I'll try the speed hacks. You have an idea what I should try?

It worked Laugh The music is normal again. Idk if I'll still slow down when I get to the part that did slow me down still the speedhacks worked. All I did was hit enable them. Thanks Dralor and Bositman.
Ok I ran into another slowdown down further into the game. Man I thought I wasn't have to worry about this anymore :/

Right now I do have speed hacks on and I tried messing with them a little but I didn't see any difference at all.

If it matters my EE is 49-60% and my GS is 19-25% during the slowdown.

Users browsing this thread: 1 Guest(s)