Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Much worse performance/compatibility on Ubuntu 17.10 vs Windows 10 w/8700k
#1
I'm trying to use PCSX2 from the daily PPA on Ubuntu 17.10. My hardware is an 8700k with an Asrock z370m ITX motherboard. I'm not trying to run in hardware mode, only software, because I do not have a dedicated graphics card. With this setup I can run most of the games I have tried so far ok in Windows 10; however, I'm having issues with performance in Ubuntu (also same in Archlinux). I'm using the latest mainline kernel 4.15 which has the drivers for coffeelake gpus. I have also tried the ubuntu kernel which also gives poor performance.

Here is a screenshot showing slow performance from a game that runs fine in Windows: https://imgur.com/a/hO0jH
It's only running about 50% speed even with 6 cores enabled in software mode. As I mentioned earlier, it is also poor in Archlinux with a git build from AUR. It is a simple 2d game. Other games like Metal Gear Solid 3 also run worse in Linux.

Another problem is that the compatibility is worse. For example, both Quake 3 and Unreal Tournament fail to load into actual gameplay, locking up at different times during loading. These games work fine in Windows.
Reply

Sponsored links

#2
This may sound ridiculous but is it possible your using D3D in Windows and OpenGL in Linux? Logically that would make the most sense to me if your not paying attention to what renderer you choose. I use Linux occasionally since I refuse to support Microsoft policies under Windows 10. Mainly I stick with Windows 7 though. Sorry I can't be of more help to you under Linux right now.
Reply
#3
Well potentially you're option are different (vsync ?). Potentially you're playing in low power mode on Linux. 99% of the code is the same between Linux and Windows so you shouldn't have such big difference.

Note: 6 extra rendering thread in GSdx mightn't give you the best performance

Edit: by the way, you do have a GPU so you should be able to use the HW renderer.
Reply
#4
(02-07-2018, 10:07 AM)[]HP[]Hawkeye Wrote: This may sound ridiculous but is it possible your using D3D in Windows and OpenGL in Linux? Logically that would make the most sense to me if your not paying attention to what renderer you choose. I use Linux occasionally since I refuse to support Microsoft policies under Windows 10. Mainly I stick with Windows 7 though. Sorry I can't be of more help to you under Linux right now.

No I use OpenGL software mode for both Windows and Linux with identical settings. Both the performance and compatibility is much better in Windows.

(02-07-2018, 10:53 AM)gregory Wrote: Well potentially you're option are different (vsync ?). Potentially you're playing in low power mode on Linux. 99% of the code is the same between Linux and Windows so you shouldn't have such big difference.

Note: 6 extra rendering thread in GSdx mightn't give you the best performance

Edit: by the way, you do have a GPU so you should be able to use the HW renderer.

I have vsync disabled on both Windows and Linux. I don't see any power saving mode in the options in Ubuntu. The only thing I saw on the Wiki was the option i915.i915_enable_rc6=1 which I turned off but had no effect. I tried 4 extra threads instead and it had no effect. I also tried hardware mode but it ran way worse, about 20% speed. It also doesn't explain why some games just would not work in Linux while they would in Windows.

edit: Quake 3 and Unreal Tournament seem to have issues on Windows too so I guess compatibility is the same so far.
Reply
#5
It is rather strange, compatibility should be the same. Speed wise some people tolds me that Linux was faster than windows for the sw threads (but it could depends on cpu model).

It is strange that hw renderer is that slow. Are you sure that you install a correct 32 bits gpu driver.
Reply
#6
(02-08-2018, 12:16 AM)gregory Wrote: It is rather strange, compatibility should be the same. Speed wise some people tolds me that Linux was faster than windows for the sw threads (but it could depends on cpu model).

It is strange that hw renderer is that slow. Are you sure that you install a correct 32 bits gpu driver.

I installed whatever the PPA recommended to be installed. As far as I'm aware there is only one open source driver for intel so I don't know what else it could be using. The compatibility is the same so far after I tested Quake 3 and UT in Windows which also had problems.
Reply
#7
gregory.. I actually see the same thing on fedora 27, though the performance difference is slight.. maybe 5-10 fps difference..

Ok guys.. here is a question for ya.. are your systems hitting their turbo frequencies? I wonder if we're not properly configured (in my case its probably my own ignorance) regarding what we would call performance profiles in windows..
amd tr 1950x 
asrock x399 taichi
XFX Radeon rx570
32gb gskill ddr4-3200
Windows 10 Pro
enermax liquitek tr4 240
nzxt 340 case
Reply
#8
(02-08-2018, 03:56 AM)scythefwd Wrote: gregory.. I actually see the same thing on fedora 27, though the performance difference is slight.. maybe 5-10 fps difference..

Ok guys.. here is a question for ya.. are your systems hitting their turbo frequencies? I wonder if we're not properly configured (in my case its probably my own ignorance) regarding what we would call performance profiles in windows..

I've run cinebench in Linux and get better scores than I do in Windows. Pic: https://i.imgur.com/ikdye1x.png
Reply
#9
xenphor - like I said.. its probably a configuration issue on my end.. but something isnt triggering a ramp up in cpu freq for me.

using lscpu, my cpu frequency is hovering between 800 mhz and 2600 mhz, even on max limiter. My ee stays below 50%, my vu stays below 20%. This isn't what I see in windows. In windows, my EE jumps to 90% + when I go into max limiter, and my cpu frequency jumps to 3100 and stays there.. I dont think its a pcsx2 issue exactly (running 1.4.0 because it is what is in my repos.. I've not compiled from source to play with yet), but for some reason its not triggering the cpu frequency scaling. I'll have to play with cinebench and see if I see the proc hit my turbo frequency.

Also, looks like you have an OC on that linux run.. is that a solid guess?
amd tr 1950x 
asrock x399 taichi
XFX Radeon rx570
32gb gskill ddr4-3200
Windows 10 Pro
enermax liquitek tr4 240
nzxt 340 case
Reply
#10
(02-08-2018, 04:52 AM)scythefwd Wrote: xenphor - like I said.. its probably a configuration issue on my end.. but something isnt triggering a ramp up in cpu freq for me.

using lscpu, my cpu frequency is hovering between 800 mhz and 2600 mhz, even on max limiter. My ee stays below 50%, my vu stays below 20%. This isn't what I see in windows. In windows, my EE jumps to 90% + when I go into max limiter, and my cpu frequency jumps to 3100 and stays there.. I dont think its a pcsx2 issue exactly (running 1.4.0 because it is what is in my repos.. I've not compiled from source to play with yet), but for some reason its not triggering the cpu frequency scaling. I'll have to play with cinebench and see if I see the proc hit my turbo frequency.

Also, looks like you have an OC on that linux run.. is that a solid guess?


No that Linux test was at stock, don't know why it's much slower in Windows. I used to get around 1410 in Windows when I first got my pc but can't get past 1400 anymore.
Reply




Users browsing this thread: 1 Guest(s)