NTSC2PAL & returning PAL2NTSC issue
Like the title of the thread says.

First I want to say hi to everyone cause this is my first post.

I haven't been using this emu so much time but I've recently encountered a problem that affects to the fps.

I can run every game at full speed but that's not the problem.
When I had a ps2 and a TV that only supports a PAL system when I've wanted to play a game that I had and it was on NTSC, I had to patch the ISO with a program like ps2vfix or ps2_ntsc2Pal_yfix. The game works great at full speed on my ps2 and my ps3 runs it great too. But when I want to play it at pcsx2 the console shows these messages:

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPS_258.15;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
Overall 0 Cheats loaded
Overall 0 Widescreen hacks loaded
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps

And the FPS doesn't go more than 50fps.

I've tried to reverse the patch doing the opposite operation without success, the emu shows that again.
I've searched at the "inis" and I found that the vsync was disabled so I don't know what to do at this point.

Any ideas? Thanks Smile

Sponsored links

remake your iso from your DVD without applying the patch, and you should do good.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
50FPS is correct for PAL. You patched your game to run in PAL mode and that also sets the frame rate to 50FPS.
Thank you both but

(12-22-2014, 10:17 AM)rama Wrote: 50FPS is correct for PAL. You patched your game to run in PAL mode and that also sets the frame rate to 50FPS.

the Ps2 and Ps3 only changed the colour and the y position of the screen, the framerate didn't vary. The iso was originally Ntsc (programmed to run at 60fps) and the emu detects that first.

I can remake the iso but some of those original are damaged and other them was moded like the Sparking Meteor (japanese tenkaichi 3) music modded (I lost the programs music, and the links of this are dead).

Is a bit strange that the only that blocks the framerate to 50fps thinking that is Pal even patching the iso back to ntsc, is the pcsx2 and not the ps2 or ps3.

PD: I tried checking the async sound and changing the framelimit of turbo to run the game at 60fps, but some games like the pcsx2 settings says, doesn't work right. Some crashes, and the sparking meteor one shows the ghost effect glitch of the pal version.

I'm a bit curious of what is happening in the emu. xD
What is that updatevsync command? What of the iso is calling it?
For the actual consoles that 50 and 60 aren't FPS, they are the machine refresh rate, dictated by hardware and won't change unless modded. So no surprise there.

The patch is confusing the emulator which is trying to play at the specified speed for the TV standard, so it will play at 50 FPS if PAL is detected or 60 FPS if NTSC, that is the expected behavior. Maybe some dev will look at this specific case of yours but I won't count on it since patched games are beyond the emulator's responsibility and the devs are already overloaded with current issues.

Good luck.
Imagination is where we are truly real
I would say you have an ntsc region bios. That sets the framerate initially to 60Hz. Later you try to read a PAL-patched disk that will switch the output to 50Hz.

But what is actually your problem?

Users browsing this thread: 1 Guest(s)