Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NamCollection help (NTSC-J, SLPS-25500)
#1
Bug 
So, upon searching the forums, I have only found one other thread about this issue, and that one was closed because (to sum it up) someone had a bios version that was uncommon, and a mod (no names will be named) closed it because it seemed a little suspicious. I'm not putting this in the bug report forum, as I'm afraid I'll do it incorrectly and most likely be warned for it.

This game does not start at all. I have multiple times tried and tried again, but I have had no luck. I actually own this game, and I tried the only other dump online that I could find (I'm not saying where, and or how to get it), and it still doesn't work. I have made GS dumps, a log, a blockdump and a savestate, and I have compressed them in case you want to try it. The blockdump has very little in it, as this game barely boots. It reads to a specific sector and then the game just stops. The VM still runs, as the fps counter is changing, and the EE/GS use is changing as well.

Though I can play this on my playstation 2, I'd like to play it on my computer as well so that way I could play it on the go. I know a laptop isn't the best thing to be using, but this is the only windows computer I have, well other than using wine on my mac, but that just doesn't work as I'd like to, as it's very slow.

My specs are 2.40GHz Intel Core i5 M 520, my RAM is 4GB, and the graphics I have is Intel HD Graphics, as I figure it's probably an on board Graphics Processor, and I know this isn't the optimal way of running PCSX2, but this is really the only way I can do this. 

I have USA BIOS 1.60 (07/02/2002), and the way that I dumped my bios is with PS2Ident, as I never used the dumping tool that you guys recommended, but I still dumped my legitimate bios from my console (I also dumped my 70001, but I didn't use that one). I used software rendering with GSdx, but I also have tried with HW rendering as well, and I'm running this with DirectX 9.

This game boots to a black screen, and I hope that this might be able to help in some sort of way. I am using 1.5.0 dev 2211.


Gameboi64
I apologize in case this was posted in the wrong place and I am inconveniencing anyone, but I needed a way to get help with this.


Attached Files
.7z   NamCollection.7z (Size: 4,3 MB / Downloads: 46)
Reply

Sponsored links

#2
Did you try using EE/IOP interpreter to see if it boots? Also, are you reading directly from the disk, or did you rip it to an .ISO?

Side note: Since these are PS1 games included in the collection, it's possible it could be using the PS1 backwards compatibility (which we don't fully support quite yet) to emulate the games on the real PS2 hardware.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#3
As far as I know for the moment, I have not tried the interpreters yet. I am using the actual disc, but I have tried ripping it as well. One thing I know for sure is that after snooping around the files of the disc, these are games on their own, as in, they have been ported to the PS2 hw, and they all reboot the PS2 hardware (mostly a hunch, because tekken has it's own elf) in PS2 mode, not ps1 mode. The strangest thing is that it boots right to ps2 mode, not ps1 mode. It could possibly be the way the video is encoded (if needed I could provide a sample), but I doubt it.

I have tried the ps1 mode with namco museum encore, it was quite buggy, but it just goes to show how far pcsx2 has come.

I just remembered, I am running Windows 7 Professional, but as far as I know, the os shouldn't affect that much. I'll get around to testing the interpreters as soon as possible and get back to you on that.
Reply
#4
(10-16-2017, 07:12 AM)CK1 Wrote: Did you try using EE/IOP interpreter to see if it boots?

I just did that, and currently, it still doesn't boot, the only thing different was that it used the EE more.

I also looked, and it actually doesn't use the GS on the black screen (surprise, I know), I forgot to mention that.

Upon further investigation, no PS2 game actually boots into a PS1 mode, as that would also cause it to be incompatible with some of the development hardware (debuggers).

I tried ripping it to an ISO, there is no difference.
Reply
#5
I patched this few months ago to atleast make some menus load, but it still got stuck after some time. I will have a look at this again after my current tennis tournament ends on this friday.
Reply
#6
Oh I messed with this game once on pcsx2. I never got it to boot either but if it is any help I can actually get at the very least TEKKEN.ELF to boot off of the disc via run elf file on pcsx2's boot options but no luck trying to figure out a way to get other games to load.
Reply
#7
(10-19-2017, 02:07 AM)Vokadae Wrote: Oh I messed with this game once on pcsx2. I never got it to boot either but if it is any help I can actually get at the very least TEKKEN.ELF to boot off of the disc via run elf file on pcsx2's boot options but no luck trying to figure out a way to get other games to load.

If I'm not mistaken, the rest of the games point to a specific offset in SLPS_255.00 to boot the other games and even the menus. This is uncommon, but not unheard of. If it's possible to extract the data and have PCSX2 boot off of that, or even a modified retail console and reburn it to a disc, they'd be pretty smart. The different elf files is also not unheard of, as Sonic Gems Collection did it as well for Sonic the Fighters, Sonic R, and (in a special way, it's complicated) Sonic CD.

It's left up to question why they only did that only for Tekken, I figure it was probably an issue with keeping it in the regular boot ELF, so they had to move it out. It's also that they probably wanted to save as much space as they could by keeping all the other games in SLPS_255.00, because the game takes up almost the whole disc, missing about 70MB for it to be the whole disc as far as I know.
Reply
#8
I know that by this point I'm bumping a (basically) dead thread, but I recently tried this with the GSnull plugin, and even though it doesn't load any video when the game starts (the emulator doesn't, as the GS just locks up anyways), testing it without any video output didn't change anything, unless that's not at all what GSnull is for. I think it might have something to do with the last IOP module it loads, which is "NGYSND.IRX". I don't know whether this is the full issue, but I don't often see a modulr load with "1 args 1 arg". It reaches "loadmodule: id 36, ret 0", reads one last 2064 block and stops. I don't know if this is any help to anyone, but I thought that any bit of help that I could provide would help with the progress of this emulator.

One quick thing, could the GameDB say that the game status is no longer "Unknown", but is "Nothing" for the time being in the emulator?
Reply
#9
The GameDB just never got updated when the game was last tested, so it still lists the game as doing "Nothing"

By the way, uploading a blockdump here would be the best solution. The option is in the Misc. drop-down menu. After you enable it, reboot the VM and do everything as you normally would.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#10
Enjoy two more screens. lol Tongue


Attached Files
.zip   Namco 50th Anniversary Collection [SLPS 25500](J).zip (Size: 274 bytes / Downloads: 20)
Reply




Users browsing this thread: 1 Guest(s)