Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Namco X Capcom Full FPS
#1
I'm trying to play namco x capcom and so far its been emuating ok but I've been having a few quarks. I have been having to choose between smooth gameplay and smooth audio output. When I have all the speed hacks enabled with ee cyclerate at 3 and vu cyclesteal at 0, I get about 45-50fps on the ingame-map (think of fire emblem) and 60fps in menus and in battle. Even though my FPS is below 60fps the game runs smoothly without any hiccups but my sound lags. When I move vu cycle steal to 2+ I get 60fps all throughout.(1 has no effect) the sound runs smoothly but the game lags on the map

Computer Specs:
Windows 7 64bit SP1
Intel Core 2 Quad 8200 2.33GHZ
Nvidia Geforce 240 GDDR5 512MB
GSDX SSE 4.1 DirectX10 (Hardware)


P.S
>Also when I used the new svn and used the 3core option it decreased my FPS so that is not a solution
>It doesn't matter what resolution I put the game on, when I put it on native I get the same FPS as when I put it on 6x scaling
Reply

Sponsored links

#2
post pcsx2_vm.ini please?

(in [code] tags prefered)
Reply
#3
pcsx2_vm.ini
Smooth Audio, Laggy Gameplay (60FPS)
Code:
[EmuCore]
CdvdVerboseReads=disabled
CdvdDumpBlocks=disabled
EnablePatches=enabled
EnableCheats=disabled
ConsoleToStdio=disabled
HostFs=disabled
BackupSavestate=disabled
McdEnableEjection=enabled
MultitapPort0_Enabled=disabled
MultitapPort1_Enabled=disabled
[EmuCore/Speedhacks]
EECycleRate=0
VUCycleSteal=3
fastCDVD=disabled
IntcStat=disabled
WaitLoop=disabled
vuFlagHack=disabled
vuBlockHack=disabled
[EmuCore/CPU]
FPU.DenormalsAreZero=enabled
FPU.FlushToZero=enabled
FPU.Roundmode=3
VU.DenormalsAreZero=enabled
VU.FlushToZero=enabled
VU.Roundmode=3
[EmuCore/CPU/Recompiler]
EnableEE=enabled
EnableIOP=enabled
EnableEECache=disabled
EnableVU0=enabled
EnableVU1=enabled
UseMicroVU0=enabled
UseMicroVU1=enabled
vuOverflow=enabled
vuExtraOverflow=disabled
vuSignOverflow=disabled
vuUnderflow=disabled
fpuOverflow=enabled
fpuExtraOverflow=disabled
fpuFullMode=disabled
StackFrameChecks=disabled
PreBlockCheckEE=disabled
PreBlockCheckIOP=disabled
[EmuCore/GS]
SynchronousMTGS=disabled
DisableOutput=disabled
VsyncQueueSize=2
FrameLimitEnable=enabled
FrameSkipEnable=disabled
VsyncEnable=disabled
ManagedVsync=disabled
LimitScalar=1.0
FramerateNTSC=59.94
FrameratePAL=50.0
DefaultRegionMode=ntsc
FramesToDraw=2
FramesToSkip=2
[EmuCore/Gamefixes]
VuAddSubHack=disabled
VuClipFlagHack=disabled
FpuCompareHack=disabled
FpuMulHack=disabled
FpuNegDivHack=disabled
XgKickHack=disabled
IPUWaitHack=disabled
EETimingHack=disabled
SkipMPEGHack=disabled
OPHFlagHack=disabled
DMABusyHack=disabled
[EmuCore/Profiler]
Enabled=disabled
RecBlocks_EE=enabled
RecBlocks_IOP=enabled
RecBlocks_VU0=enabled
RecBlocks_VU1=enabled
[EmuCore/TraceLog]
Enabled=disabled
EE.bitset=0
IOP.bitset=0

Smooth Gameplay, LAggy Audio (45-50FPS)
Code:
[EmuCore]
CdvdVerboseReads=disabled
CdvdDumpBlocks=disabled
EnablePatches=enabled
EnableCheats=disabled
ConsoleToStdio=disabled
HostFs=disabled
BackupSavestate=disabled
McdEnableEjection=enabled
MultitapPort0_Enabled=disabled
MultitapPort1_Enabled=disabled
[EmuCore/Speedhacks]
EECycleRate=2
VUCycleSteal=0
fastCDVD=enabled
IntcStat=enabled
WaitLoop=enabled
vuFlagHack=enabled
vuBlockHack=enabled
[EmuCore/CPU]
FPU.DenormalsAreZero=enabled
FPU.FlushToZero=enabled
FPU.Roundmode=3
VU.DenormalsAreZero=enabled
VU.FlushToZero=enabled
VU.Roundmode=3
[EmuCore/CPU/Recompiler]
EnableEE=enabled
EnableIOP=enabled
EnableEECache=disabled
EnableVU0=enabled
EnableVU1=enabled
UseMicroVU0=enabled
UseMicroVU1=enabled
vuOverflow=enabled
vuExtraOverflow=disabled
vuSignOverflow=disabled
vuUnderflow=disabled
fpuOverflow=enabled
fpuExtraOverflow=disabled
fpuFullMode=disabled
StackFrameChecks=disabled
PreBlockCheckEE=disabled
PreBlockCheckIOP=disabled
[EmuCore/GS]
SynchronousMTGS=disabled
DisableOutput=disabled
VsyncQueueSize=2
FrameLimitEnable=enabled
FrameSkipEnable=disabled
VsyncEnable=disabled
ManagedVsync=disabled
LimitScalar=1.0
FramerateNTSC=59.94
FrameratePAL=50.0
DefaultRegionMode=ntsc
FramesToDraw=2
FramesToSkip=2
[EmuCore/Gamefixes]
VuAddSubHack=disabled
VuClipFlagHack=disabled
FpuCompareHack=disabled
FpuMulHack=disabled
FpuNegDivHack=disabled
XgKickHack=disabled
IPUWaitHack=disabled
EETimingHack=disabled
SkipMPEGHack=disabled
OPHFlagHack=disabled
DMABusyHack=disabled
[EmuCore/Profiler]
Enabled=disabled
RecBlocks_EE=enabled
RecBlocks_IOP=enabled
RecBlocks_VU0=enabled
RecBlocks_VU1=enabled
[EmuCore/TraceLog]
Enabled=disabled
EE.bitset=0
IOP.bitset=0
Reply
#4
block hack always causes issues

also you should use a newer SVN with microVU. and I would use software rendering with 3 threads
Reply
#5
Its disabled in the first setting though, I tried disabling in the 2nd setting and I still got sloopy audio. I'm starting to think that the sloppy audio is due to not having 60FPS, so we should probably try to figure out why the game slowsdown with vu stealing at 2, with all other hacks off.

edit: I just tried software rendering with 3 threads I got the same results for both settings as I did for hardware
Reply
#6
that's easy. vustealing produces false readings
Reply
#7
could you explain "false readings"?
Reply
#8
(06-04-2012, 01:54 PM)xanmato Wrote: could you explain "false readings"?

well false reading meaning is not real
e.g. you max-out VU cycle stealing and you see max speed 60(64)fps but the game screen feels slow that is false reading.
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#9
(06-04-2012, 01:58 PM)tallbender Wrote: well false reading meaning is not real
e.g. you max-out VU cycle stealing and you see max speed 60(64)fps but the game screen feels slow that is false reading.

Any idea on why the audio output is smoothed out when VU cycle stealing is maxed out? Is there any way to speed up output through the SPU plugin so that the sound comes out alright in the 45-50FPS enviornment and if there is what values should I put
Reply
#10
So I havent played in a week and decided to try again, I was looking at the configuartion guide and thought that maybe I could play with 45-50fps and use the Async Mix plug-in. It says that it
Quote:"Makes the audio out of sync with the video, so you will get normal sound speed even if your frame rate is not optimal. Can cause games to hang or crash so use with caution!"
inside the 9.8 configuration guide, so is it possible to get 60FPS Sound output even though the game runs at 45-50fps. What latency setting should I use and should i disable reverb effect/change interpolation?
Reply




Users browsing this thread: 1 Guest(s)