Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Native Mac Testing Build
see post #153
Reply

Sponsored links

I've ran multiple versions of PCSX2 on my old Windows PCs but I could never get them to work on my MacBook. I'm pretty excited that I can get my .iso's to run with this and they don't look bad at all. 

But, I am having huge issues with my controller. I'm using some cheap PS2-USB controller from Amazon and I've tried the SDL2 Gamepad Tool but I couldn't get a good calibration. It looks like it's made for Xbox controllers and I'm not really sure what to do here since it won't calibrate with my analog sticks, is there an option to switch it to Dualshock that I'm missing? Also, I've seen a couple of people's OnePad2.ini and tried their mappings with no success, and also my "uid[0] = 0" so I'm not sure if my controller is really being seen. There is an old OnePad 1.1.0 floating around that I've read can be calibrated but the installer does nothing for me. 

If someone got the controller to work, I'd definitely appreciate a quick YouTube tutorial if possible, it doesn't seem too hard to do but it just isn't working for a lot of people in the thread. 

Below is my OnePad2.ini, after mapping my PS2-USB to the Xbox layout (doesn't read the analog sticks), no responses in the OnePad Plugin menu at all. 

first_time_wizard = 0
log = 0
options = 0
mouse_sensibility = 100
ff_intensity = 32767
uid[0] = 0
uid[1] = 0
PAD 0:KEYSYM 0xb = 2
PAD 0:KEYSYM 0x12 = 12
PAD 0:KEYSYM 0x13 = 15
PAD 0:KEYSYM 0x14 = 13
PAD 0:KEYSYM 0x15 = 14
PAD 0:KEYSYM 0x3b = 1
PAD 0:KEYSYM 0x69 = 4
PAD 0:KEYSYM 0x6a = 7
PAD 0:KEYSYM 0x6b = 6
PAD 0:KEYSYM 0x6c = 5
PAD 0:KEYSYM 0x6e = 11
PAD 0:KEYSYM 0x70 = 3
PAD 0:KEYSYM 0x76 = 8
SDL2 = 03000000790000000600000007010000, VILROS PS2USB,platform:Mac OS X,a:b2,b:b1,x:b3,y:b0,back:b8,start:b9,leftstick:b10,rightstick:b11,leftshoulder:b4,rightshoulder:b5,dpup:-a1,dpdown:+a1,dpleft:-a0,dpright:+a0,lefttrigger:b6,righttrigger:b7,'
Reply
For those that are curious/interested, here is the result of some informal testing of the 2020-07-27 build of PCSX2 on my M1 MBP with 16GB of ram. These are not complete plays of the games, just quick loads to see what is willing to start up. At this time, only the OpenGL HW renderer works on the new Apple Silicon systems, OpenGL SW crashes every one of these games.

Activision Anthology - Okay, once you get past the memory card prompts (hidden on a blank screen)
Capcom Classic Collection - Okay
Capcom Classic Collection Vol 2 - Okay
CastleVania Curse of Darkness - Okay
CastleVania Lament of Innocence - Okay
Disgaea Hour of Darkness - Okay
Disgaea 2 Cursed Memories - Okay
FF XII - Blank screen with audio at start, game plays fine after new game/load game selection
Grandia II - Okay
Grandia III - Okay
Intellivision Lives! - Okay
Kingdom Hearts - Blank screen with audio
Megaman X Command Mission - Okay
Midway Arcade Treasures - Okay
Midway Arcade Treasures 2 - Okay
Midway Arcade Treasures 3 - Okay
NAMCO Museum - Okay
NAMCO Museum 50th Anniversary - Okay
Onimusha Warlords - Okay
Phantasy Star Generation 1 - Blank screen with audio
Phantasy Star Generation 2 - Okay
Phantasy Star Universe - Stuck at PlayStation 2 boot logo
Phantasy Star Universe Ambition of the Illuminus - Stuck at PlayStation 2 boot logo
Shin Megami Tensei Nocturne - Okay
Sly Cooper and the Thievius Raccoonus - plays, but very slow. just trying to get to the start menu it runs between 0.98 fps and 16 fps. The same behavior occurs with Play! under Rosetta 2 using both OpenGL and Vulkan renderers. Disabling framelimiting does not improve speed.

With the exception of Thievius Raccoonus, all games ran at 98-101% speed & between 58 and 62 fps. (Especially the ones that stayed at blank screens.)
Reply




Users browsing this thread: 1 Guest(s)