Need Help With Optimization
I've been able to get PCSX2 working on my desktop, and I'd say everything is working correctly, except for one minor detail...lag.

I used the guide to set things up and I went back and looked through the FAQ, Wiki and some of the guides but what I'm reading is telling me mostly to just "try different settings" to see if it fixes it.

I was hoping that instead of randomly changing settings that could FUBAR something, I could possibly just post my setup info and someone who is familiar enough with this setup could give some advice on how to speed things up (because at this rate even though there are no graphical issues, the speed makes it unplayable).

So here's the rundown:

Hardware Side:

  1. AMD A6-3670K APU with AMD Radeon 6530 HD Graphics 2.7GHz
  2. 8 Gigs of RAM
  3. GeForce 9500 GT, DirectX 11, Pixel Shader 4.0 (All DirectX Libraries updated)
  4. Windows 7 OS

PCSX2 Side:

  1. GSdx 5334, SSE2 - Direct3D 10 (Hardware) - All the rest set at default values
  2. Running US BIOS v02.30 (02/02/2008)
  3. All remaining settings through out the emulator are left at default
  4. I've confirmed that the games I'm using are listed in green at 100% compatible on the sites compatibliyt list. Currently I'm testing with all the old WWE Smackdown Vs Raw games (2006-2011) and Legends of Wrestling

If I've left any important info out please let me know. Any help in getting this lag issue resolved would be much appreciated.

Sponsored links

You can try:

1. Tick Native in GSdx

2. Enable speed hacks including MTVU

3. Play around with Allow 8-bit textures option in GSdx and see which one gives you more FPS

4. Go to Config -> Emulation Settings, at EE/IOP tab, change Clamp mode to None, the same goes for VU tab.
Thanks for the info, I gave it a try along with some tweaking on my own (along with pretty much throwing the kitchen sink at it) and here's my results:

Quote:1. Tick Native in GSdx

2. Enable speed hacks including MTVU

3. Play around with Allow 8-bit textures option in GSdx and see which one gives you more FPS

4. Go to Config -> Emulation Settings, at EE/IOP tab, change Clamp mode to None, the same goes for VU tab.

  1. This was already ticked before
  2. This was also already enabled by default
  3. Checked the 8-Bit texture option - RESULT = No Difference
  4. Turned both Clamp modes to "None": RESULT = No Difference

I'm using WWF Smackdown: Shut Your Mouth as my benchmark and I recreate the same match every time. It seems the entrances lags in the high 40 FPS and the in-ring game play gets a performance increase but not fully (it only reaches about 50-55 FPS). Here is a screen shot of the status bar stats from when the game is running:

[Image: pcsx201.png]

So, in an attempt to continue to troubleshoot this on my own here is a list of various things I tried (based on what I read in the "Official Guide") that I though could help speed things up. Here are the results:

  1. Disabled Texture Filtering
  2. Set the audio to 0-Nearest and Disabled Effects
  3. Set the EE Cyclerate Slider to 3 and the VU Cycle Stealing Slider to 2

RESULT = I noticed that the audio seemed to speed up and the frame rate in the status bar held strong at around 59-60 FPS. However, the game itself actually seemed to slow down EVEN MORE than before, as if it were in some kind of slow motion.

So, finally, I tried over riding all these settings and using the "Aggressive" and "Aggressive Plus" presets.

RESULT = Nothing changed, pretty much back to my original state where the entrances drop to around 45 FPS and the in-ring game play works OK but is still not full speed (right around 50-55 FPS).

As I said before I've pretty much thrown the kitchen sink at it and with a quad-core processor, plenty of RAM and a decent 9500 GT graphics card I'm confident it's not a lack power. So needless to say I'm stumped.

Any thoughts?
Quote:as if it were in some kind of slow motion.

Slider based speed hacks were causing this, especially VU Cycle Stealing.

This is known as fake FPS.

And keep in mind that AMD processors have bad performance with PCSX2.
I'm a complete noob but when it came to performance for me it was because I had 2 different graphic cards, one being the crummy Intel chip set that came with my system. If you have 2 cards (you have a desktop so it's probably not likely) then make sure your emulator is using the GeForce. Also, if you have the option, make sure that the hardware hacks are disabled
The game is demanding and you have an AMD CPU.
It's apparent from your screenshot (EE at 92%) that your CPU just can't take the load and that's to be expected. That A6 is simply not fast enough for these games, which are known to be demanding. My suggestion would be to try again with some games from this list:
[Image: newsig.jpg]
Is it because I only have a quad-core processor or because the quad-core I have is not ideal (IE: would a quad-core Intel processor work)? This is the first time I've ever heard that an AMD processor was not the best choice for gaming. I've always heard they ruled the roost in the area.

Also, give it to me straight. Is it possible that no matter what settings combination I try in PCSX2 that, with my current hardware setup, I'll never get these games to run on my system properly?

The number of cores isn't as important as their execution speed and Intel had a strong lead there for years now.

I understand that you're close to good speeds anyway though, so maybe a little CPU overclock can help.
I see. Over-clocking isn't a good idea for me as I've had issues with that on this system in the past and the negatives far outweighed the positives.

So, is it a for gone conclusion that unless I get more CPU power there is no combinations of settings with my current hardware that will get this up to snuff?

Users browsing this thread: 1 Guest(s)