Need some patch help (solved)
SOLVED. Thread can be locked or something (tried to delete it myself, but seems regular users don't have that permission despite seeing the delete option)

Using PCSX2 0.9.5 on Yu-Gi-Oh! Duelists of the Roses (U), I found that its pnach name should be 07AD79C9. Through the patch finder I found that the code, which I found by searching for a 16-bit value, is:
So, I make a pnach file, change patch=0 to patch=1, give it a value of 0001 (I want it to be 1), but it doesn't do anything. What's wrong? I tried both the old 0.9.5, and 0.9.8 (turning cheats on, of course).

This is my pnach file (edited from when I first posted this), now using a guide I found as a reference. I also learned that the console of 0.9.8 will show some information if you use a correct pnach file, and it did indeed show the comment and that a cheat is loaded and such. Yet no effect, while I definitely have the correct address.

gametitle=Duelists of the Roses
comment=Min DC

Sponsored links

patch=0 mean the cheat will be loaded once, when the game is loaded, it did not worked as well as expected so is rare to see use. Do not confuse with disabling the code.

patch=1 - the code is applied once per game frame.

The code must be for the same region the actual game is. Remember the code for 0,1 and 2 (byte, short and word) just peek the value (operand) and push it into the given address, the patcher will do it without further question. If the code is "wrong" the memory will be changed anyway and possibly compromising the game in a way which may render it unplayable ahead. Saving such corrupted memory in a sstate perpetuates the issue forever (unless the game is normal saved and loaded from that save, which hopefully will clean the memory corruption so newer sstates will be clean).

The boton line is, if the code doesn't work, either the whole concept that changing that address will do what you want... or the address itself are wrong.

Once applied, the memory change is kept even if the code is disabled. That's the reason a game should never be sstate saved if a cheat seems not to work (make sure to quit the emulator, correct or disabe the code before loading the game again). Doing a sstate over a corrupted memory grants the error return whenever that corrupted sstate is reloaded.
Imagination is where we are truly real
I found the error. I tried finding the address again, using the exact same method. Again only 1 address left over with the correct value... but it was a different address this time Wacko And this one works all the time, so it's not that the game uses multiple addresses and picks a random one. Really weird how doing the exact same thing twice lead me to different results (and yes, the address I found at first had the correct value as well).

So, this is solved. I can't seem to delete my thread though, as I get an error. Are regular users supposed to see the delete option?

Users browsing this thread: 1 Guest(s)