Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No Video Mobile Intel 945 in HW Mode
I get no video with Mobile Intel 945 Graphics chipset when in Direct3d9 Hardware mode. Can anyone help. The Only Error msg I see is

C:\Program Files\PCSX2 1.0.0\resource(1671,15): error X4532: texlod not supported on this target

Don't know if That has something to do with it, can anyone help?

Sponsored links

i don't have suggestions for your error, but i can tell you that even if you can run pcsx2, you won't go far with that card
pcsx2 1.0.0 dont support 950 gma . use 0.9.8

And then do whatever you wanted to do anyway...

(sorry for my bad english, i am french Cool )
gma 950 uses a different chip to the 945, so its not really comparable.

however, from all the testing i've done lately, there isn't an intel graphics chip that doesn't have problems in some way, with gsdx.
well i heard from more than one member for now that they're having problems running their GSDX Direct3d9 (HW) as for those very OLD IPU
don't fully support DX9 as it seems ( SW mode works fine ) Smile
yes the (sw) mode work fine ,but thw (hw) show a black screen the soluce is just use a good graphic card nvidia,ati; or wait for a new version of pcsx2 i gess

And then do whatever you wanted to do anyway...

(sorry for my bad english, i am french Cool )
Thanks for all the replies, Yes its 945 not 950, but i will give v9.8 a try anyway. I have tried the newest SVN versions which the commits say there are fixes for some intel chipset issues, but the SVN gsdx plugin crashes with a runtime error every time. Yes, I am aware that even if it works the performance will suck on this hardware, but it should be better than running it in software mode (hopefully). I've only been using the Windows version BTW, no linux installed on this machine ATM. I think I'll install it and see if the linux version behaves differently. Thank you all for the help.
The latest changes were for the Intel on-die chips, meaning the new HD 3000, HD 4000 etc not for the old Intel GMAs
[Image: newsig.jpg]
Also I tested In the old Ati GPU x800 pro same problem "error X4532: texlod not supported on this target" in the news revision GSdx plugin
not much help hardware/software option.

But Plugin Zerogs and ZeroOGL Running ok Tongue
[Image: mypc.gif]
Hardware mode last worked in GSDX r5036 (leave extra rendering threads at zero, or the emu will crash). It works with the 1.0 release, too. I hope this can be fixed in a newer version of GSDX.

Users browsing this thread: 2 Guest(s)