Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No interlacing codes
#41
The character's face changed, is that an artifact of the patch?
Reply

Sponsored links

#42
(10-29-2018, 04:38 PM)CK1 Wrote: The character's face changed, is that an artifact of the patch?

No just a different animation

I tried Bouncer and it's still blurry. I guess the game has a different issue, probably some post-process filter or gsdx glitch.

Had no luck with Soulcalibur 2 or 3 either, they must use a different method than the one mentioned in the tutorial. Oh well Sad
Reply
#43
Can someone explain how exactly one goes about finding these codes? I'm a complete amateur at this. I have no idea what the sceGsSetHalfOffset let alone how to find and patch it. What exactly am I searching for? where am I to look for it? I really want to make Ace Combat 0 work with no interlacing and less blur. But I don't have a clue how to do it on my own.
Reply
#44
see post #34
Reply
#45
@RadiantYeti
I posted the code for ace combat

@synce
I think there is some misunderstanding about these codes
The codes are meant to disable the image shaking inherent from interlacing and how field rendered games are displayed
They are not disabling post process effects like motion blur, bloom etc... those are implemented differently per game(every dev with their own routines)
The codes for games like GT3 or the Ace combat series and others which uses a 480p backbuffer will give you a clearer picture simply because we display this backbuffer instead of the downsampled 240p front buffers which are blurrier then the backbuffer(maybe the confusion arised from this?)
Anyway as far as the interlacing is concerned The Bouncer is using the standard sceGsSetHalfOffset, I posted a code for the US version in the past.
The game is using heavy motion blur as a form of antialiasing and probably for artistic reasons too.
If you want to see the game without post process you can set the byte @00323C08 to zero, and the motion blur is gone. Be aware the hud is gone too, and the pause menu is not displayed.
This is not disabling the routines which are responsible for the motionblur, is just a quick brute force to not display some buffers. If you want an elegant method you will have to dig in into the code and find the routines.
forgot to mention soul 2and 3 have native 480p modes, no need for code @synce
Reply
#46
(11-09-2018, 05:27 PM)asasega Wrote: @RadiantYeti
I posted the code for ace combat
Oh, Thank you very much! Biggrin
Reply
#47
(11-09-2018, 11:42 PM)RadiantYeti Wrote: Oh, Thank you very much! Biggrin

Wait, you posted the SLUS_213.46 Ace Combat Zero: The Belkan War CRC = 0x65729657 I know the pnach file for this game but I don't know what to do with it to find the right codes to fix the interlacing. Do I need to use cheat engine to find the right codes?

Edit: Nevermind, I found it. Still, this is an interesting technique. Could you elaborate on how you found these codes? For example, you said in your instructions that "When the game is running you search(the search range of course is the PS2 emulated RAM)" Where exactly am I searching for that? is it the Console, the Debug window or something else? Also, the FMVs seem to play at 24fps with interlacing disabled instead of the 60 fps they usually do. Any way to fix this? If not, I don't care that much. But I'm just curious
Reply
#48
If possible, I'd like to add a request for SLUS_213.59 Metal Gear Solid 3: Subsistence CRC=0x053D2239
The Mini Box
i5-4690K @ 4.5GHz | 8GB DDR3-1600 | Gigabyte Z97N-WIFI | EVGA GTX 1050Ti SSC | HyperX 120GB SSD | Seagate Barracuda 1TB 7200RPM HDD | EVGA 600BQ
Windows 10 Pro 64-bit


Reply




Users browsing this thread: 1 Guest(s)