No sound
Hello, my brother has the same config that I have in my pc and he has no sound with pcsx2 games.
He is using SPU2 - X and has all unchecked.

Any idea?

Sponsored links

go to plugins selector screen. then configure spu2-x. go to module section. it is possible ur brother has 'no sound' option selected. change that to 'x-audio 2' or 'directsound'
[Image: lhljdGn.png]
My Steam Profile
Intel i7 8086k @ 4.0 ghz | Nvidia Gtx 980ti 6GB | Corsair Vengence pro 16gb DDR4 | WD Blue 1tb + Black 2tb hdd | Samsung 850 Evo 250gb SSD | Windows 10 pro

No, he has "Portaudio (crossplatform)" selected
(02-23-2014, 06:48 PM)Toaro Wrote: No, he has "Portaudio (crossplatform)" selected

Well still try and change it to the ones suggested above.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
I didn't read that part, my fault, sorry.

Solved, he changed the option to x-audio2 and it works

Thank you
I did have a similar problem after playing with the new version (1.2.1). I thought at first "OK, WASAPI is a new feat in SPU2-X, so it's on?". Checked the config, Portaudio was selected, clicked on Configure, yep, WASAPI was on. I tried Exclusive Mode, sound worked after that.

Normally you'd probably want XAudio2 though, especially if you're listening to music, on skype, etc. But, if you want WASAPI and sound isn't working, try Exclusive Mode. If it still don't work, you're SOL. Use XAudio2 or Directsound.

Quick question: Ever tried implementing ASIO support in the SPU2-X plugin?
ASIO is something we wanted but it is copyright of Steinberg, so wed have to buy a license to use it.
[Image: ref-sig-anim.gif]


Users browsing this thread: 1 Guest(s)