Odd behaviour of Turbo mode - Ratchet & Clank
This is fairly strange, so I decided to post it here, god forbid I might be onto something.

So, I'm playing Ratchet & Clank (With my Original PS2 disk I bought in a store a long time ago, and using the Bios from my good old PS2 that I have obtained in the manner described on this site).

As you perhaps know it's one of those games with terrible texture problems in hardware mode.

Now, let me say I'm running PCSX2 0.9.8 (r4600) with the SSE4 video plugin.
I have several speed hacks enabled aswell.

Of course, I try switching to software mode and it runs surplisingly well. It's slow but fairly fluid and all texture problems have been solved (there are some rare instances of all textures from a train's model getting screwed up, I've encountered it only once and affected both hardware and software mode)

And well, here comes the curious part.

If I turn TURBO MODE ON while in software mode, the game is extremely fluid, with no graphical problems.

The only issue is that while the game runs fluid and at what seems to me like the correct speed, the audio is very fast.
Is there a way to prevent turbo mode from affecting the audio?

Sponsored links

You could try setting the "Synchronizing mode" in SPU2-X to Async, it may not work or give sync issues or break your game later on tho so use at your own risk Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
You can try SPU async in the sound plugin configuration. Default it's timestretch. It MAY break this or other games (don't have ratchet and clank to try it myself) and not sure how turbo mode effects the option... but it's worth a try and does work for other games that just run a little slow.

(edit) Slow typing Tongue2
[Image: 2748844.png]
That did seem to make the audio's timing better, thanks.

Still, I find it fairly odd that Turbo makes Software mode so good.
I wonder if it will work the same on other games I had issues on.

Users browsing this thread: 1 Guest(s)