Odin Sphere[PAL-M5] [SLES55110]
# PCSX2 version: SVN, Official 1.0
# CPU options: EE/IOP defaults, VUs defaults, No speedhacks
# Plugins used: GSdx 0.1.16 rev 5442, also tested some older revisions back to rev 4xxx (dx11, dx9, hardware, software), SPU2-X v2 rev 5445
# Description: There seems to be a bug in GSdx hardware mode that makes a graphical glitch in Odin Sphere. There are box-like shapes visible around some of the sprites, that dissapear when using software mode. I tried some of the old revisions of GSdx back to rev 4xxx, but it´s still there. Could it be ATI driver specific bug? I also tried some of the offset hacks found in Gsdx but they made it worse.

My specs: Phenom II X4 955, Radeon HD 5850 Catalyst 12.10

Here are some screenshots, it´s best visible on the third one, around the bird. The image compression hides it a lot.

[Image: pcsx2_2012_11_10_16_51_05_42.jpg]

[Image: pcsx2_2012_11_10_16_56_00_18.jpg]

[Image: pcsx2_2012_11_10_16_57_20_71.jpg]

Sponsored links

(11-11-2012, 01:35 PM)Medard22 Wrote: I also tried some of the offset hacks found in Gsdx but they made it worse.

hmm, the wild arms offset hack should do it for that... the half pixel offset one wont Tongue

what does it look like with the wild arms offset hack?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
I tried both. Wild Arms offset hack doesn´t fix it. Full hack makes it look even worse. The first picture is Wild Arms offset hack half option, the second is the full one.

[Image: pcsx2_2012_11_11_13_31_02_34.jpg]

[Image: pcsx2_2012_11_11_13_32_03_58.jpg]
hmm, you might have to play with the resolution then, are you using the custom resolution or the #x native options? Im pretty sure the wild arms offset hack will give different results depending on the resolution chosen, possibly better using the #x native options.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
I believe it'll only work right in some select custom resolutions and in native mode, of course.
I am using 4x native resolution, but the borders are visible even in native resolution. Wild Arms offset hack in native didn´t resolve it either.

Here it is in the native resolution, full option hack and half option hack. The third picture is the custom resolution 1280x1024 with no hack applied.

[Image: pcsx2_2012_11_11_20_43_13_02.jpg]

[Image: pcsx2_2012_11_11_20_43_32_18.jpg]

[Image: pcsx2_2012_11_11_20_51_44_19.jpg]
online photo storage
Native resolution with no hacks, of course Tongue2

Did a quick check and I don't get these glitches at all, even with x3 scaling.
Make sure you don't have any GSdx hacks enabled.
Yeah sorry Smile it´s present in native resolution as well and I normally don ´t use any hacks. I ´ll try to set up a separate latest svn build and try to run the game. Rama you have nVidia or AMD gpu?
Ok so I´ve set up a separate build from the latest SVN. I´ve kept default settings, only disabled the speedhacks. In GSdx I used DX11 hardware, native resolution, no hacks applied. The glitch is still present. If it works ok for you, could it be a video drivers thing? I´ve been tampering with catalyst control center trying different settings but with no luck.

[Image: pcsx2_r5450_2012_11_12_19_02_24_49.jpg]
upload pic
I can definitely replicate the issue you can see in the first picture, around the Valkyrie text box. It does appear in native res, but goes away sometimes if you come from the right instead of the left for some odd reason. It seems to be completely fixed in 2x native and I can't get it to re-appear there, but comes back again in 3x. There may well be other custom resolutions that work, but 2x native with no hw hacks seem to work, for this at least. Can't speak to other issues 'cause I'm too lazy to dig out my saves from the PS2 HDD, but if you upload a memcard I could take a look at those.
This is on r5423 and an AMD GPU btw.

Users browsing this thread: 1 Guest(s)