Optimize Final Fantasy X
I'm trying to properly configure PCSX2 to play Final Fantasy X at a good constant frame rate.

-OS: Windows 7
-Processor: AMD Athelon II X2 M300
-Graphics card: ATI Mobility Radeon™ HD 4200 Graphics9 with up to 19198 MB of HyperMemory™ (256 MB of dedicated system memory, up to 1663 MB of shared system memory), supporting Unified Video Decoder 2(UVD2), OpenEXR High Dynamic-Range (HDR) technology, Shader Model 4.0, Microsoft® DirectX® 10.1

Sponsored links

Don't expect to be able to play it at decent speeds. CPU apparently has a very slow clock speed, around 2ghz from what i've looked at. You have an integrated GPU too, which leeches off the CPU and memory. Even i get some slowdown on my PC during some of the more intensive spell effects.

Turn on all the speedhacks you can though in the options. I've found most can be turned on for FFX and i've not noticed any game breaking things (yet). Keep the resolution low too, native or even below. Always stick to GSdx SSE2 (which is the only one of them your CPU supports).
System- Custom Build
CPU- Intel Core i5 4670K @4.2ghz
Memory- 8GB DDR3
Video Card- EVGA Nvidia GTX 1060 6GB
OS- Windows 10 Pro x64
right now im using the newest pcsx2 [2968]. it runs very good, not crash and image is better than ever.[before, image was like piecesssss. and shaking too-im playing ffx international version..]

so u should use the newest. remember to enable ffx[option]
my setting:
gs: gsdx 2966m ssse3
pad: ...
spu2: ...
fw: ...

"..."= default setting
i did not change anything, i changed only gamefixes : enable game fixes: EE timing hack/ffx video...etc.

u should try the newest pcsx2 first. then see. i think ur pc can run ffx
edit: one of player could run ffx with this pc: . "It ran fine on my old Core 2 Duo 1.6GHz, 1GB RAM, 128MB Mobility Radeon video (don't know the model number)."-Namida
ok thx

Users browsing this thread: 1 Guest(s)