Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Optimizing Champions of Norrath
#1
Last time I fired up the Dark Alliance games there was still a bit of slowdown here and there, but I have since upgraded my computer and also I'm no longer overheating my CPU due to a fried fan! Wewps.

Specs:
i7-7700k
1070GTX
16gb ram
windows 10 64bit

I was still using 1.5 dev build ~600 and I played through dark alliance 1 & 2 with very minimal slowdown. Good times. I have since moved on to Champions of Norrath which has had very minimal slowdown throughout the first act, but I just made it to the lava place in act 2 (right after the ant queen) and I'm dropping below 30fps and I'm not entirely sure why. It seems like the goelms are the main culprits of the biggest slowdowns but the whole area will randomly slow down and speed up a little bit. I picked up the latest build and looked up some settings on the wiki and I had a couple things that were a little off, but it didn't change anything. 

https://wiki.pcsx2.net/index.php/Champions_of_Norrath

These are the settings I am following currently. Playing on x2 resolution, but can play on x6 with no impact to the fps and the slowdown areas still drop to the same levels. Is there something I'm missing or are the snowblind games still not quite perfected?
Reply

Sponsored links

#2
What your GSdx settings?
Reply
#3
I set everything to match the wiki. Before I looked on the wiki my skipdraw was 0, and blending unit accuracy was none (fastest)


Attached Files Thumbnail(s)
   
Reply
#4
Yeah you're using an really old dev build, you should get the latest one here: https://buildbot.orphis.net/pcsx2/

You also don't need to use skipdraw or Fast Texture Invalidation, you should disable that. Try those first and see if your speed improves.
Reply
#5
Actually fast texture invalidation was made specifically for the snowblind engine games, so he does need that.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
Try basic for blending accuracy and MTVU on/off. Game likely reads the frame buffer into CPU. It is the slowest thing in the universe and nothing can be done (except no read it).
Reply
#7
(03-23-2018, 02:46 PM)gregory Wrote: Try basic for blending accuracy and MTVU on/off. Game likely reads the frame buffer into CPU. It is the slowest thing in the universe and nothing can be done (except no read it).

Apparently it was the MTVU, I had a save state right next to a golem and when I loaded in it was running mostly smoothly. As soon as I found 2 golems on the screen at the same time it started to drop again, but only down to about 40-45 until I killed one then it went back up to 55-60. So it's definitely the golems that are causing the problems. Outside of that it seems like there are constant little stutters, nothing too noticeable with no negative effect on gameplay but its just not quite smooth while running around. It might just be this particular area though. Snowblind created games that are too awesome to emulate.

Someone had mentioned to get the latest dev build, I am on the latest (2329) as of last night. I initially mentioned I was still on ~600 because when I moved everything to the latest build there were no improvements performance-wise. I also wasn't using skipdraw to begin with until I started getting the FPS drops in the fire area, and when I set the skipdraw to 4 it had no impact on performance. What is skipdraw suppose to do and should I just keep it set to 4? Since I've always played with MTVU on, is it still safe to use better settings? Higher resolution, blending accuracy (if its even required? I don't really know what its doing anyway). Always appreciate the help in these forums, I love this community Smile
Reply
#8
Skipdraw does what it suggest since it skips the drawing of things and the higher the number the more it skips and use a number to high and ou can loose both effects and hud elements and other random things. So drop it back down to 0. For example in FFX and FFXII setting skipdraw to 1 will remove the annoying blur effect when you have a higher than native resolution set. and it does different things in different games since they are alll programmed differently.

As for optimizing Snowblind egine games theres not much else you can do besides use the settings you have already set and try mtvu on and off and see if one or the other helps for some people they get better performance with in on others see better fps with it off so yeah. Allow 8bit textures and Fast Texture Invladavtion are the 2 needed hacks for the Snowblind Engine games.You are going to see slowdowns no matter what you do you and it helps if you turn off Widescreen hacks and zoom the ca,era in all the way as it causes less to be rendered thus allowing higher FPS.
Reply
#9
I encountered another issue unrelated to fps. I just defeated the undead army and killed the boss, tried to load into castle Vanarhost and it sat on the loading screen. I checked the log and it kept repeating:

0xc [load]
(EE pc:001444F8) TLB Miss, addr=0x2 [load]
(EE pc:00144414) TLB Miss, addr=0x4 [load]
(EE pc:00144414) TLB Miss, addr=0xc [load]
(EE pc:001444F8) TLB Miss, addr=0x2 [load]
(EE pc:00144414) TLB Miss, addr=0x4 [load]
(EE pc:00144414) TLB Miss, addr=0xc [load]

I restarted PCSX2, tried to reload the same area and it did it again. I put my game disc in the drive and it loaded the next zone just fine. I saved the game, restarted via the ISO, and when I tried to load into the castle this time it crashed PCSX2. I remade the ISO from my disc and it didn't crash it this time so I managed to save a log. Any ideas? Hopefully it will continue to run off the disc.

'gothic1.gob' not found
(EE pc:00165180) TLB Miss, addr=0x0 [store]
'gothic1.gob' not found
(EE pc:00165180) TLB Miss, addr=0x0 [store]
(EE pc:003050D4) TLB Miss, addr=0x2573288 [load]
(EE pc:003050FC) TLB Miss, addr=0x2573288 [load]
etc.

'gothic1.gob' not found
cpuTlbMiss pc:3050d4, cycl:f6cbdfe9, addr: 1f90342e, status=70030c11, code=8
cpuTlbMiss pc:3050fc, cycl:f6cbdfec, addr: 1f90342e, status=70030c13, code=8
etc.
Reply
#10
Bad ISO can easily cause issues like that.
Reply




Users browsing this thread: 1 Guest(s)