Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Out of memory error when exiting PCSX2
#1
As stated in the title, whenever I hit exit to close the program an out of memory error gets thrown and I have to manually close the log after the rest of the program has shutdown. It seems this only happens after running a game as simply opening then exiting PCSX2 does not throw this error. I also have quite a bit of red text regarding my audio setup, anybody who could clue me in on that would be appreciated!

Ubuntu 16.04 LTS
MSI GE72VR-027
i7-6700hq
Intel HD Graphics 530
Nvidia GTX 1060(Mobile)
32 GB DDR4
512 GB M.2 SSD
1 TB SATAIII HDD


Attached Files
.txt   log.txt (Size: 8,57 KB / Downloads: 262)
Desktop:
Ryzen 7 5800X | MSI MAG CORELIQUID 360R | MSI X570 unify | 16GB [email protected] MHz (14-14-14-34) | EVGA RTX 3070 FTW3 Ultra
500 GB WD Black SN750 | 2TB Seagate Firecuda | Windows 10 Pro x64
Laptop:
MSI GE72VR 6RF Apache Pro
i7-6700hq | 6GB GTX 1060 | 32GB [email protected] MHz | 512GB SSD | 1TB HDD
Reply

Sponsored links

#2
is your issue recent ? I updated the behavior of VU dispatcher to use memprotect, it is likely linked.
Reply
#3
I'd say it's recent I just installed ubuntu and pcsx2 again yesterday Tongue But if you looked at the log I linked memprotect is mentioned at the end of it.
Desktop:
Ryzen 7 5800X | MSI MAG CORELIQUID 360R | MSI X570 unify | 16GB [email protected] MHz (14-14-14-34) | EVGA RTX 3070 FTW3 Ultra
500 GB WD Black SN750 | 2TB Seagate Firecuda | Windows 10 Pro x64
Laptop:
MSI GE72VR 6RF Apache Pro
i7-6700hq | 6GB GTX 1060 | 32GB [email protected] MHz | 512GB SSD | 1TB HDD
Reply
#4
Is MTVU on/off ?
Reply
#5
All default settings except for i changed it to 2x native and i think I have it on the sse4 plugin
Desktop:
Ryzen 7 5800X | MSI MAG CORELIQUID 360R | MSI X570 unify | 16GB [email protected] MHz (14-14-14-34) | EVGA RTX 3070 FTW3 Ultra
500 GB WD Black SN750 | 2TB Seagate Firecuda | Windows 10 Pro x64
Laptop:
MSI GE72VR 6RF Apache Pro
i7-6700hq | 6GB GTX 1060 | 32GB [email protected] MHz | 512GB SSD | 1TB HDD
Reply
#6
(12-04-2016, 02:34 AM)Carsomyr Wrote: I also have quite a bit of red text regarding my audio setup, anybody who could clue me in on that would be appreciated!

I believe Ubuntu also uses PulseAudio by default. I had the same problem with sound on my Mint system (Ubuntu-based). Change your SPU2-X output settings to use the SDL Audio Module and set your SDL API to pulseaudio and it should quit spamming the console about ALSA buffer underruns.
The Mini(ITX) Box V2 a.k.a. Nighthawk
Ryzen 7 3700X | 16GB DDR4-3600 CL16 | ASUS ROG Strix B550-I Gaming | EVGA GTX 1660Ti SC Ultra Gaming | Sabrent Rocket 4.0 NVMe 1TB | Samsung 860 EVO 1TB SSD | EVGA 600BQ
Windows 11 Pro 64-bit
Reply
#7
If you have too much underrun, you can tune the latency value too.
Reply
#8
So far, I didn't manage to reproduce it. Unfortunately, we miss linux tester so I don't know if everybody is impacted.
Reply




Users browsing this thread: 1 Guest(s)