Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Overheating
#1
My laptop keeps cutting out when I'm using PCSX2 to play Disgaea: Hour Of Darkness. It's definitely because of overheating. I read the General FAQ and it gives the usual tips about airflow etc. but I'm wondering if there's anything I can do in the settings to cool things down.

Disgaea is a turn-based game with crude graphics, so I'm willing to sacrifice performance/graphics for cooler running temperature.

I don't know whether this helps, but it only overheats on certain maps. For the randomly generated item world maps it runs hot but doesn't cut out, but for some of the story maps it has issues. I guess the randomly generated ones have plain textures and the story ones have more detail or something, but I don't really know what I'm talking about.

In short, is my laptop's integrated graphics card (Intel HD Graphics 3000) simply not up to the task? Or is there anything I can do settings wise?
Reply

Sponsored links

#2
There is not much you can do, and the overheating is not a result of your integrated graphics either.

PCSX2 is heavily CPU bound and it pushes CPUs very hard. In the case of laptops or desktops with stock cooling this can cause heat issues. Unfortunately there are no real settings you can change that will affect that much.

You can maybe set the EE cycle rate hack to position 2 or 3. That might get you a little leeway(doing that is effectively underclocking the PS2 emotion engine which can make it easier on the CPU, but it only works with some games, others it won't affect).
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
Okay thanks. I'll give it a try.

I forgot to mention that I did try lowering the maximum processor state from 100% to 99% as per this video...

https://youtu.be/4i1X7LvMi9k

...and that helped (it would cut out with about a minute of starting the game before I did that).
Reply
#4
normally, it would overheat at demanding scenes for your processor to handle. that's probably why it overheated on certain specific scenes.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
(04-14-2015, 01:42 PM)ssakash Wrote: normally, it would overheat at demanding scenes for your processor to handle. that's probably why it overheated on certain specific scenes.

I've just discovered a solution (kind of). I ran task manager while playing the game and noticed that the CPU usage went up whenever I did anything. So I just tried pausing, just a little, between each action and it's holding at about 40-50% which isn't enough to overheat it.

Being a turn-based game, it's fine to take a little time to think.

I'd actually been playing it even more hurriedly than normal - "Gotta finish this turn before it cuts out!" - without realising that was making the problem worse.Biggrin

Thanks to both of you for pointing out that the CPU, and not the graphics card, was the problem.Smile
Reply
#6
(04-14-2015, 01:55 PM)SuperMassiveGav Wrote: I've just discovered a solution (kind of). I ran task manager while playing the game and noticed that the CPU usage went up whenever I did anything. So I just tried pausing, just a little, between each action and it's holding at about 40-50% which isn't enough to overheat it.

Being a turn-based game, it's fine to take a little time to think.

I'd actually been playing it even more hurriedly than normal - "Gotta finish this turn before it cuts out!" - without realising that was making the problem worse.Biggrin

Thanks to both of you for pointing out that the CPU, and not the graphics card, was the problem.Smile

Well if that option is okay for you, the best way would be to suspend PCSX2 instead of pause.

When you want to take a break, press ESCAPE. The GSdx Window will close. When you want to resume, go to system->resume.

This will have the effect of completely dropping your CPU to no usage and letting it cool rather quickly.

(As a small note, make sure you don't have "Close emulator on ESCAPE" set in lilypad config. It's OFF by default, but if you turned it on, obviously this would completely close the emu and lose your progress)
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#7
(04-14-2015, 02:01 PM)Blyss Sarania Wrote: Well if that option is okay for you, the best way would be to suspend PCSX2 instead of pause.

When you want to take a break, press ESCAPE. The GSdx Window will close. When you want to resume, go to system->resume.

This will have the effect of completely dropping your CPU to no usage and letting it cool rather quickly.

(As a small note, make sure you don't have "Close emulator on ESCAPE" set in lilypad config. It's OFF by default, but if you turned it on, obviously this would completely close the emu and lose your progress)

Oh, I don't even mean pausing that much. Just a few seconds every few actions or so.

The thing is just NOT to play it like the seasoned pro that I am. A slower, more thoughtful pace overall seems to make a lot of difference.

But actually, your suggestion might be useful during some of the LONG set sequences that, despite being little more than text and static images, seem to heat things up a lot.
Reply
#8
Well another option is to outright slow it down instead of pausing. You can use the hotkey SHIFT+TAB to turn on slowmo, which will drop the FPS to half, and thus the CPU usage as well, while still allowing the game to run(just at half speed).

You can alter the slowmo speed to whatever you like in Config->emulation settings->GS and changing "Slow Motion Adjust"
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#9
Now that is exactly the kind of thing I was hoping for when I started this thread. It's just fine at 75% slomo. Thanks again. Much appreciated.

(so addicted to this game)
Reply
#10
*****, about a minute after I posted that last message it cut out again Huh

I looked at the CPU usage just before it cut out because I heard the fan speed up and it was only at about 20%.

Could any (or all) of the following contributed to the problem?

- Listening to music on iTunes
- Playing full screen
- Having this forum thread open and posting in it.
Reply




Users browsing this thread: 1 Guest(s)