(PAL) Altered Beast emulation problem/ game bug?
Today while playing PAL version of Altered Beast on pcsx2 1.2.1 i encountered weird bug - people who played this title knows that there are green "transformation meter" that constantly goes down when you transform to a beast, and it worked as it should so far (also played this on actual ps2 so i can confirm).

While gaming today i noticed that this meter was not depleting at all at some point, no reason at all, just like some enabled cheat for unlimited gauge.

After exiting emulator and playing again the meter was depleting normally, but what could be the culprit of encountered bug? Could that be emulator issue (never had this on actual PS2 and I played quite a lot at this game) or maybe some game bug that i triiggered somehow?

Using pcsx2 1.2.1 latest stable, PAL 2.0 bios, dx11 HW mode with 3x upscaling, enabled nvidia hack and widescreen patch applied (also checked "enable widescreen patches" in menu).
Core pcsx2 settings not touched, speedhacks only recommended enabled by default.

Sponsored links

Could be anything if you can not reproduce it.

But these artifacts are the reason for savestates being considered as unstable. The game just can have a logical glitch and there is nothing you can do to repair it but to freshly restart the system.
Tried going into same place, fighting same enemies with same moves but didn't manage to reproduce this again (so far, we will see if this occurs again during playthrough).

I wonder if some bug in emulator can result in issues like this? I was always thinking that all that emu can bug are some glitched graphics and wile somethink is not right like the game is programmed to be, then emu (pcsx2 or any other) would crush, but not alter gameplay in any way.
Also saw some time ago post of user who suposedly had timing issue in Wild Arms 3 that made some dungeon not passable due to no way of triggering some time based puzzle.

Users browsing this thread: 1 Guest(s)