PCSX 0.9.6 Freezes Vista
I recently downloaded the new version of the PCSX and when I run the game, the system freezes. It's weird because i could play games normaly on 0.9.4. I played KH and FFX before.
And now I am trying FFXII, but I doubt the game itself is a problem. When I load the game, the system freezes and if I pres ctrl+alt+del, the emulator continues to load the game and it manages to load it properly, because I can play the game without any problem. The FPS rate is quite good and the CPU is constantly at 5-10%, while in the movies it jumps to around 50%.
This is bugging me, because even the CPU is not overloaded, but Vista is not responding to anything. Only the ctrlaltdel combination works, and I have to log off, to actually close the program.
Anyways the old version worked fine, without any problems. And I have the latest DX10 installed.

What could cause the system to freeze? If you need any additional info, just ask.

Sponsored links

try the betas, it was fixed in one of those
My Laptop:
CPU: intel T4200 @ 2.0 ghz
GPU: Intel GMA X4500M
Ram: 3 Gb DDR2
SO: WinVista Home Premium // Windows 7 Ultimate x32
It's the same with the last beta. I freezes when trying to load the GS plugin.
Uhm did you update your DirectX? if you installed 0.9.6 in the same folder as the old one it'll have problem loading old plugins, it'd be better if you installed it ina new folder.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
My DX10 is up to date. I have also installed it in a new folder. I tried closing all the unnecessary programs. And I also left the task manager open, to see the CPU load and it never got higher than 60%, yet vista is still unresponding.

I tried this with the official release and with the beta.
Okay, I tried almost everything now and it still doesn't work.
-I tried with FFX and it's all the same.
-I tried the new beta plugins and the beta emulator.
-I even updated my graphics card drivers.
-I installed the service pack 2 for vista.
-I tried the other graphics plugins and it doesn't work.
-I tried with the original DVDs, as well as creating ISO images.
-I closed all the programs running in the background.

I'm guessing it's not the plugin's fault but rather the emulator itself. I tried the new plugins with the old 0.9.5 emulator and it worked perfectly fine, although FFXII doesn't run with full speed.
The problem is the same, when it loads the GS plugin, the whole system freezes. If I press ctrlaltdel, the emulator resumes with the loading, but the system remains unresponsive. If i press the ctrlaltdel again, the game starts and it plays normally, but the system is still unresponsive.
The only way to quit the emulator is to force the log out through the ctrlaltdel combination or to hard reset the computer, that I rather not do frequently.
Maybe my specs will help:
-HP pavilion hdx 9000 (gaming laptop)
-Windows Vista Home Premium SP 2
-ATI mobility radeon HD 2600 XT
-3GB of RAM
-Intel Core Duo 2.2 GHz

Hope this information will help with fixing this problem.
Reinstall pcsx2. Then try it again.
CPU: Core i5 Processor 3330
RAM: 16 GB
OS1: Windows 10
Oh I did that. Several times.
Whoops my bad. Didn't see the previous post. Maybe wait until pcsx2 0.9.7 comes out?
CPU: Core i5 Processor 3330
RAM: 16 GB
OS1: Windows 10
I guess I have no other choice. Hope this will be fixed in the next version. Or even better, in one of the next betas.

Users browsing this thread: 1 Guest(s)