PCSX2 0.9.8 Messed up graphics
Whenever I run GTA San Andreas the graphics are not normal.

[Image: 13836792.png]

However if I enable 4x AA it looks a little better.

[Image: ssaa4.png]

CPU -> Intel E5300
GPU -> 9800GT
RAM -> 2GB

GS -> ZZOgl 0.3.0
PAD -> OnePad 0.1.0
SPU2 -> SPU2-X 1.4.0
CDVD -> EFP Polling CDVD 0.4.0

Also happens when booting the bios, and this error is produced when booting into the bios:

GIFTAG warning, size exceeded VU memory size 400
GIFTAG warning, size exceeded VU memory size 400
If any more information is needed just ask.

Sponsored links

I get the exact same thing on my Ubuntu Natty machine with a Core i5 2400 and Nvidia GT240 with Nvidia Binary Driver 270.41.19.

It happens in both the Bios screen at startup and inside of games. The only game I have right now is Wild ARMs 5 and it's experiencing the same distored graphics. Upping the AA to 16x makes everything look alot better, but it renders the program unusable because it is so slow.

Could someone please give some advice?
Can you create a screenshot inside the bios, it seems to be fine on my side. I saw the sony logo, can navigate into the options. Did you try the hack inside zzogl? Use default pcsx2 options too.

Another possibiliies is that zzogl is not yet compatible with those games.
Just as a mention, I'd make sure Anistropic filtering is off in the nvidia control panel, as that'll produce blocky graphics along that line.
that would make it a bug in zzogl even if it was a setting in the driver control panel.
It's a setting to force on Anisotropic filtering on programs that were not designed to use it. Doing this will occasionally cause bad results with programs, and pcsx2 is one of them.

It's been an issue when using ZeroGS in Linux since at least 2006, and ZZOgl is based off of it.
The information required for AF sampling is available in the resources, the plugin is scrambling the sample data for god knows what reason.

Its pretty amusing to blame a function that can apply to API's made before the technique was even implemented in gfx drivers.

I could accept AA breaking things but if AF is causing havok, something is defintely wrong.
On the fglrx driver it seems to work with AF to the max Tongue2

Anyway, AF is very old, extension was implemented back in 2000 !
(06-09-2011, 10:54 AM)arcum42 Wrote: Just as a mention, I'd make sure Anistropic filtering is off in the nvidia control panel, as that'll produce blocky graphics along that line.

Well that fixed the blurred image, but now when I boot into the bios after I select my language it flickers, same with GTASA startup. After I get pass the intro movie, which doesn't appear, I get this.

[Image: 60366461.png]
I had a similar result with the the ZZogl with either blank screen or blocks.
So tried gsdx with 9.9 using gsdx I get a ghost image.

The ghost image has persisted from Ubuntu 10.04 (pcsx2 ver 9.7 and 9.8) through 11.10 using both an ATI and Nividia Card. It does run fine in Win 7 ver 9.8 but gets the same ghost image using wine for the same.

I have also tried both from the original PS2 DVD and an ISO image of it.

I have been google'in it for 7 months so I thought it was time to ask for help

AMD|ATH II X3 435 2.9G AM3
4 gig DDR3 ram
GeForce 8400GS 1024 MB DDR3
Integrated ATI Radeon HD3000 512 MB
Original PS2 so Bios Ver v01.60

Users browsing this thread: 1 Guest(s)