Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 0.9.8 won't work
I recently had my pc updated to windows 7 64bit, and the graphics card updated to a nVidia 8800gt and now the PCSX2 will not work. It displays a message saying the following:

You need to update some directx libraries, would you like to do it now?

(I click yes and it starts to download direct x9 even though I have 10/11, then the install stops and says)

An internal system error occured.
Please refer to DXError.log and DirectX.log in your windows folder to determine problem.

(I cannot find this file when I type it into search or in the windows folder as I do not know which folder it is in, I then click ok and this message appears on PCSX2)

The selected GS plugin failed to load.

Reason: The plugin reports that your software/hardware are not supported.

C:\Program files (x86)\PCSX2 0.9.8\Plugins\dsdx-sse2-r4600.dll

All plugins must have a valid selections for PCSX2 to run. If you are unable to make a valid selection due to missing plugins or an incomplete install of PCSX2, then press cancel to close the configuration panel.

I tried reinstalling, which moved the files to the (x86) program files, no idea what the difference is between the normal one and this, but the error appears again. I also tried changing the GS plugin to direct X10/11 but it still says the same message. Can anyone help me sort out this problem? or does the PSCX2 simply not work on windows 7?

Sponsored links

just get directx yourself on MS website and install it.

It'll work better this way.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
K Im trying but the MS website is a pain to navigate. I downloaded a damn PowerPoint slideshow talking about directX 11. So now Im downloading something called DXSDK, which I think has directx 11. Question tho why do I have to install Directx if it is already on the computer? did it not install properly or something?
You may not have the latest update.
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
The directx install is still coming up with errors. :/
You don't need SDK(Software Development Kit) except if you're building PCSX2 yourselfSmile. Just this:
k thx for the link PSCX2 works now Laugh thx alo and Ill let ya know if there are any new probelms Laugh

Users browsing this thread: 1 Guest(s)