PCSX2 1.1.0 Ubuntu 12.10 64bit and ZZOGL0.4.0 freeze
Hey folks, after searching the web for about 3 days and getting my libs messed up a couple of times ( by applying various suggestions to my problem ) I figured out that I maybe will get a better chance to solve my problem when I post it here.

First sorry if my english isn't that perfect ... I'm not a native-speaker :/

So let me give you an overview of my current specs:

Distribution: Ubuntu 12.10 Quantal 64Bit

Nvidia GTS 450 GLH driver-version 310.14 / also tested with 304.56

Intel® Core™ i5 CPU 760 @ 2.80GHz × 4

6 Gb RAM

PCSX2-Version: 1.1.0 using gregorys-ppa

BIOS-Version Europe V 02.0

Okay let me come straight to my problem:

I tried to use the ZZOGL plugins 0.3.0 and 0.4.0 ( cause GSDX is working but the graphic is realy clustered - seems like no AA at all ) but evrytime I switch to that plugins the screen will freeze after loading the game.

The terminal-ouput stops at "ZZOgl-PG: Capturing ZZOgl window." and then I have to kill it. I allready tried to switch the VU to Nearest and None but no change after all. Dunno if I missed something, feels like I had some more facts in mind ... feel free to ask I will try to support as much as I can.

Greetings and in hope for answers

Sponsored links

You are definitely not alone regarding trouble with ZZogl. Here is a very recent thread for essentially the same problem.


This same problem would give me trouble too. For some reason, giving it a few tries consecutively by attempting to load the game and killing it when the screen turns black (essentially a seg fault) would eventually lead to it working all of a sudden. I still don't know why ZZogl would just start working all of a sudden but it would.

Instead of retelling that long story from the attached thread just read it over as some have found the problem fixed through different means. If all else fails just make the game crash and do a gdb on it and attach the info.

Regarding the GSdx problem, you say graphics are "clustered." Got any screenshots? I'm not sure what you mean.

Also, are you sure you have the 32bits version of all necessary dependencies installed?
Sorry I need to update the ppa with the latest fix of zzogl. Don't have time to do it now, I will try to do it this week but it isn't a promise.
Thank you for the quick answers!


I'v followed evry possible hint in that threads before posting here :/ but nothing changed so far.

And thanks gregory for your effort, take your time. Feeling good to know that you'r still working on it. Think I will be patient then, means that this thread is obsolete

And here's what I meant with "clustered" GsDx-Plugin Software-Emulation with AA1 enabled

[Image: Screenshot_from_2012_11_06_22_17_04.jpg]
When it comes to anything related Linux, it seems like patience is a virtue.

Anyways, regarding your screenshot, that is how my FFX looks. That's the joy of SW mode. Native resolution only, which isn't the prettiest, but hey, at least it works. Tongue
Haha yea I don't mind that much playin' this way - but I had the hope that the ZZOGL-Plugin would come with better graphic or HW-Mode? Anyway I will have to wait for the patchday or compile it in chroot I guess.

Thanks for your patience. I uploaded a new ppa version. If it builds fine, it would be available in a couple of hours.
Hey gregory,

thanks for the patch! Now 0.4 runs smoothly ( won't start with 8x AA either but with 4x ). Much appreciated! Plz keep up the good work

Users browsing this thread: 1 Guest(s)