Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 1.4.0 Crash Every Time Loading ISO
So, I just recently installed the PCSX2 1.4.0 update, and I  am pretty sure I have everything set up correctly; but every time I try to start any ISO, the whole emulator just insta-crashes and closes, saying "PCSX2 has stopped working." I've tried looking for solutions, but none of them seem to help. It crashes and closes on its own so there doesn't seem to be a way for me to get a log.
I am using both US Bios 2.20 and US ISOs. (From EmuParadise)
I am not using an overclocked card
I am using native Direct3d 11 settings
I have changed my SPU2 to DirectAudio (and all the others still not working)
Not using any gamefixes or Speedhacks (I've tried the gamefixes, but don't seem to work)

PC Specs

CPU.....................Intel core i5-4690K CPU @ 3.50GHz, 3501 MHz, 4 cores, 4 logical processors
Motherboard..........MSI Z87-G41 PC Mate (MS-7850)   
Hard Drive............Western Digital Caviar Blue 1TB 3.5" 7200RPM 
Memory................2x - Patriot Memory, 2400 CL11 Series, 8GB-DDR3
Video Card.............ASUS Zotac GeForce GTX 970 4GB 
Operating System...Microsoft Windows 10 Pro (64-bit)

Sponsored links

(05-09-2016, 01:48 AM)syleaux Wrote: I am using both US Bios 2.20 and US ISOs. (From EmuParadise)

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!

Users browsing this thread: 1 Guest(s)