Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 1.4.0 Won't recognize my game -.-
#1
I am running a ripped ISO of Eternal Ring, ripped from a friend's copy of the game with offbrand software, and compiled from .I00, .I01, and MDS files using ImgBurn, and when I mount the Disc Image File to Drive E, and run it, it asks me to Please Insert a PS2 Format Disc. What have I done wrong here? I'm running the US Bios, as it's a US copy of the game, but I am perplexed. When I try to run it as simply an ISO file, the emulator crashes, with no error message generated. Any ideas? Sorry if my post is not along the proper guidelines, I'm a brand new member. If anything I've said isn't allowed, please let me know, and lock/delete this thread.

Thanks,

A perplexed FromSoft fan.

Sponsored links

#2
I've tried repairing my C++, using the recommended .exe, I've tried changing my video plugin several times, and I've tried recompiling the files into a new Disc Image File, and none of it has worked. I'm still at an absolute loss here -.-
#3
tried using directly your original disc instead of all the hassle you've been through to remake an iso ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#4
I've already returned the disc to my friend, as he was still actively playing it on his PS2, or I would ;.; It's over an hour to drive out to my place, or I'd simply ask him to bring it back, so I can try that. Unfortunately, I didn't try to play it until a couple of days after he had returned home.
#5
Oh , i see.
it's not your disc and you don't own the game.

then we can't help you.

Good luck, though
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)