Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 1.5.0-0 does not start all games
#1
log
PCSX2 1.5.0-0
Savestate version: 0x9a0d0000

Host Machine Init:
Operating System =  Linux 5.4.0-28-generic x86_64
Physical RAM    =  4936 MB
CPU name        =  Intel® Xeon® CPU          X3230  @ 2.66GHz
Vendor/Model    =  GenuineIntel (stepping 0B)
CPU speed        =  2.664 ghz (4 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 0000e3bd
x86EFlags        =  20100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

Loading plugins from /usr/lib/i386-linux-gnu/pcsx2...
Bound  GS: libGSdx.so [GSdx (GCC 9.2.1 SSE2/SSSE3) 1.1.0]
Bound  PAD: libonepad-legacy.so [OnePAD 0 1.3.0]
Bound SPU2: libspu2x-2.0.0.so [SPU2-X 2.0.0]
Bound CDVD: libCDVDnull.so [CDVDnull Driver 0 0.6.0]
Bound  USB: libUSBnull-0.7.0.so [USBnull Driver 0 0.7.0]
Bound  FW: libFWnull-0.7.0.so [FWnull Driver 0 0.7.0]
Bound DEV9: libdev9null-0.5.0.so [DEV9null Driver 0 0.5.0]
Plugins loaded successfully.

(GameDB) 9768 games on record (loaded in 318ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
Opening GS
Closing plugins...
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(p) GS plugin failed to open!(thread:MTGS)(thread:EE Core)
User-canceled plugin configuration after plugin initialization failure.  Plugins unloaded.


my hwinfo
OS: Ubuntu 20.04 focal
Kernel: x86_64 Linux 5.4.0-28-generic
Uptime: 1h 3m
Packages: 2541
Shell: bash
Resolution: 1280x1024
DE: MATE 1.24.0
WM: Compiz
WM Theme: Ambiant-MATE
GTK Theme: Ambiant-MATE [GTK2/3]
Icon Theme: Ambiant-MATE
Font: Ubuntu 11
Disk: 1,4T / 1,8T (76%)
CPU: Intel Xeon X3230 @ 4x 2,667GHz
GPU: GeForce 9500 GT
RAM: 2499MiB / 4936MiB


-------------------------------------------------------
old version pcsx2 1.4.0 from Ubuntu 18.04.03 
start games no PROBLEM !!!!!! 

why???

Sponsored links

#2
Are you using latest mesa drivers?
Also are you using the sse2 plugin?
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 10 Pro 64bit
#3
(05-03-2020, 11:07 PM)lightningterror Wrote: Are you using latest mesa drivers?
Also are you using the sse2 plugin?


Driver and configuration as it was Ubuntu 18.04
#4
Wikipedia says, your GPU only has 512MB/1GB of VRAM(https://en.wikipedia.org/wiki/GeForce_9_...ce_9500_GT), probably that's not enough anymore for v1.4.0+?

According to the current specs lowest value is 2GB: https://github.com/PCSX2/pcsx2#system-requirements

Is 1.4.0 working for you? Did you install NVIDIAs properitary driver (You don't need mesa for NV)? Can you play other games/3D Applications?
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool
#5
Photo 
OS: Ubuntu 18.04 bionic
Description: Ubuntu 18.04.4 LTS
NVIDIA-SMI Driver Version: 340.108
---------------------------------------------
>>> run pcsx2 log <<<
PCSX2 1.4.0-0
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Linux 4.15.0-72-generic x86_64
Physical RAM    =  4951 MB
CPU name        =  Intel® Xeon® CPU          X3230  @ 2.66GHz
Vendor/Model    =  GenuineIntel (stepping 0B)
CPU speed        =  2.664 ghz (4 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 0000e3bd
x86EFlags        =  20100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

Loading plugins...
Binding  GS: /usr/lib/i386-linux-gnu/pcsx2/libGSdx-1.0.0.so
Binding  PAD: /usr/lib/i386-linux-gnu/pcsx2/libonepad-1.1.0.so
Binding SPU2: /usr/lib/i386-linux-gnu/pcsx2/libspu2x-2.0.0.so
Binding CDVD: /usr/lib/i386-linux-gnu/pcsx2/libCDVDnull.so
Binding  USB: /usr/lib/i386-linux-gnu/pcsx2/libUSBnull-0.7.0.so
Binding  FW: /usr/lib/i386-linux-gnu/pcsx2/libFWnull-0.7.0.so
Binding DEV9: /usr/lib/i386-linux-gnu/pcsx2/libdev9null-0.5.0.so
Plugins loaded successfully.
    This OK!!
+++++++++++++++++++++++++++++++++++
OS: Ubuntu 20.04 focal
Description: Ubuntu 20.04 LTS
NVIDIA-SMI Driver Version: 340.108
---------------------------------------------
>>> run pcsx2 log <<<
PCSX2 1.5.0-0
Savestate version: 0x9a0d0000

Host Machine Init:
Operating System =  Linux 5.4.0-29-generic x86_64
Physical RAM    =  4936 MB
CPU name        =  Intel® Xeon® CPU          X3230  @ 2.66GHz
Vendor/Model    =  GenuineIntel (stepping 0B)
CPU speed        =  2.664 ghz (4 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 0000e3bd
x86EFlags        =  20100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

Loading plugins from /usr/lib/i386-linux-gnu/pcsx2...
(GameDB) 9768 games on record (loaded in 300ms)
Bound  GS: libGSdx.so [GSdx (GCC 9.2.1 SSE2/SSSE3) 1.1.0]
Bound  PAD: libonepad-legacy.so [OnePAD 0 1.3.0]
Bound SPU2: libspu2x-2.0.0.so [SPU2-X 2.0.0]
Bound CDVD: libCDVDnull.so [CDVDnull Driver 0 0.6.0]
Bound  USB: libUSBnull-0.7.0.so [USBnull Driver 0 0.7.0]
Bound  FW: libFWnull-0.7.0.so [FWnull Driver 0 0.7.0]
Bound DEV9: libdev9null-0.5.0.so [DEV9null Driver 0 0.5.0]
Plugins loaded successfully.
Patches: No CRC found, using 00000000 instead.
Opening plugins...
Opening GS
Failed to find glCreateQueries
Failed to find glCreateTextures
Failed to find glTextureStorage2D
Failed to find glTextureSubImage2D
Failed to find glCopyTextureSubImage2D
Failed to find glBindTextureUnit
Failed to find glGetTextureImage
Failed to find glTextureParameteri
Failed to find glGenerateTextureMipmap
Failed to find glCreateFramebuffers
Failed to find glClearNamedFramebufferfv
Failed to find glClearNamedFramebufferuiv
Failed to find glClearNamedFramebufferiv
Failed to find glNamedFramebufferTexture
Failed to find glNamedFramebufferDrawBuffers
Failed to find glNamedFramebufferReadBuffer
Failed to find glNamedFramebufferParameteri
Failed to find glCheckNamedFramebufferStatus
Failed to find glCreateBuffers
Failed to find glNamedBufferStorage
Failed to find glNamedBufferData
Failed to find glNamedBufferSubData
Failed to find glMapNamedBuffer
Failed to find glMapNamedBufferRange
Failed to find glUnmapNamedBuffer
Failed to find glFlushMappedNamedBufferRange
Failed to find glCreateSamplers
Failed to find glCreateProgramPipelines
Failed to find glClipControl
Failed to find glTextureBarrier
Failed to find glGetTextureSubImage
ERROR: GL_ARB_buffer_storage is NOT SUPPORTED
GL_ARB_texture_barrier is not supported! Blending emulation will not be supported
Closing plugins...
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(p) GS plugin failed to open!(thread:MTGS)(thread:EE Core)
     NOT RUNNING!!!
    Setting as old version 

WHY ?  Sad
#6
As I mentioned, your hardware is most likely too old for versions newer than 1.4.0. Seems they implemented a hardware check, which prevents launching on insufficent hardware. Probably a dev can confirm this? Can you try to launch version 1.4.0 on your 20.04 installation?
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool
#7
GL_ARB_buffer_storage is a mandatory extension which your gpu or driver doesn't support. It's time for an upgrade. Maybe mesa driver has it implement but don't expect miracles with that gpu.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 10 Pro 64bit
#8
(05-09-2020, 09:37 PM)XXXBold Wrote: As I mentioned, your hardware is most likely too old for versions newer than 1.4.0. Seems they implemented a hardware check, which prevents launching on insufficent hardware. Probably a dev can confirm this? Can you try to launch version 1.4.0 on your 20.04 installation?

this version i can not install 
ERROR : ... libwxgtk3.0-0v5 (>= 3.0.4+dfsg)
dpkg -i pcsx2_1.4.0-11_i386.deb - all one does not want
Sad Sad
#9
Ah, well, seems 1.4.0 is not in the repo for ubuntu 20.04 anymore, instead there's a dev-build from 1.5.0.

So you can try to install all packages manually (Make sure to install the 32-bit libraries: sudo dpkg --add-architecture i386 and then always install the i386 library). Not sure if all libs are still available in 32-bit, because with ubuntu 20.04 most of these libs have been dropped.

Maybe you should just stay on Ubuntu 18.04 with your system, you still have support until 2023 and less trouble with your hardware.
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool
#10
Now the topic can be closed!

PCSX2 did not finish for the new Linux!
example of a new Fedora also problems ...

We run Wine! ver:5.8(dev)
console...
winetricks d3dx9 vcrun2013 corefonts
get pcsx2 1.2.1 -> https://pcsx2.net/download/releases/arch...1-2-1.html
install and setting GS -> OpenGL(Software)
    GoodLucky! Cool
all THX!!!!!  Biggrin




Users browsing this thread: 1 Guest(s)