Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 120 FPS Settings? ( General games but specially KH/KH2 )
#1
Hi all! As the title says: I'd like to get my PCSX2 at 120 FPS. 
I would like it for general games but if this isn't possible I would also like some specific settings for Kingdom Hearts I and II.
I'd like to set up my PCSX2 from scratch with the great help of experienced users I could find in this forum. 
From scratch I mean starting by which BIOS should fit better, Sound, Video and similar plugins 'til GS plugin settings. That's why any screenshot is not included in my post.
I would like to play at PAL versions of games as I'm italian but even U.S.A versions if these grants better performances.

I'd like to get some infos as my intent IS NOT to break any kind of rule.


PC Specifics: 

Processor: Intel I7-7700K LGA 4.20 GHZ
        GPU: Nvidia Asus 1070 8GB
        MOBO: Asus Z-170A
        RAM: 32GB Corsair Vengeance LPX DDR4 @ 2666MHz 
        FAN: Properly watercooled.
   Monitor: Asus VG248QE at 120 Mhz with Lightboost which is the main reason I'm opening this thread. 
   

I could run KingdomHearts 1 enough smoothly but with PAL limit (50) at 1920x1080 Custom resolution. I've read various fixes like the one for black lines you can find in PCsx2 Wiki. 
I've also saw some cheats for the NTSC version which makes KH run at 60 FPS, maybe even 120 but I will consider this as last chance in case.
Thanks forwarding for any kind of help
Davide.
Reply

Sponsored links

#2
To answer your BIOS question, you should be extracting the BIOS from your PS2. So what do you mean by which one would be better?
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
16 GB DDR4 RAM
Reply
#3
The best bios is the one you get from your PS2
On that pc,ypu can run the game with almost any settings.
And I doubt you'll see a difference between 60 and 120fps internal frame rate(between the default 30 and 60,it's obvious)
And keep in mind that wanting to run the game at 120fps internal speed,means that you must be able to run the game at constant 4x default speed with at 1080p
Reply
#4
For 120fps, open "inis\PCSX2_vm.ini" and change "FramerateNTSC=59.94" to "FramerateNTSC=119.88". Remember that other games will run at double the speed because of this.

Then make sure you are using the 120fps codes (only for KH2 Final Mix, IIRC) and most importantly, go to "Config" -> "Emulation Settings" -> "Speedhacks" and increase EE Cyclerate at least to 130%. Preferably 180% or higher. With your 7700K, especialle when overclocked, the game will work fine, other than some bugs caused by higher than 30fps.

You have Lightboost, so you'll know if the game drops to 60fps internally (double image in movement). Keep in mind that at 120fps the game demands exactly 4x as much GPU power too.

Edit: codes for 120fps (44D23E5F.pnach file in my case. I'm using the English translation):

// 60 FPS Kingdom Hearts 2 Final Mix
patch=1,EE,00349E1C,extended,00000000
// Half game speed
patch=1,EE,20349E0C,word,3F000000 // 3F800000
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
Reply
#5
(10-09-2017, 08:41 PM)envisaged0ne Wrote: To answer your BIOS question, you should be extracting the BIOS from your PS2. So what do you mean by which one would be better?

Well, I've did some tries with an old BIOS that I've got since time on my pc, but was wondering if any could simply performs better.

(10-09-2017, 08:43 PM)vsub Wrote: The best bios is the one you get from your PS2
On that pc,ypu can run the game with almost any settings.
And I doubt you'll see a difference between 60 and 120fps internal frame rate(between the default 30 and 60,it's obvious)
And keep in mind that wanting to run the game at 120fps internal speed,means that you must be able to run the game at constant 4x default speed with at 1080p

Could the problem come from the monitor refresh rate which is not synchronized at all with PCSX2?
Because I think the stuttering could come from this :/
+ About BIOS ^


(10-09-2017, 08:53 PM)masterotaku Wrote: For 120fps, open "inis\PCSX2_vm.ini" and change "FramerateNTSC=59.94" to "FramerateNTSC=119.88". Remember that other games will run at double the speed because of this.
Then make sure you are using the 120fps codes (only for KH2 Final Mix, IIRC) and most importantly, go to "Config" -> "Emulation Settings" -> "Speedhacks" and increase EE Cyclerate at least to 130%. Preferably 180% or higher. With your 7700K, especialle when overclocked, the game will work fine, other than some bugs caused by higher than 30fps.
You have Lightboost, so you'll know if the game drops to 60fps internally (double image in movement). Keep in mind that at 120fps the game demands exactly 4x as much GPU power too.

Edit: codes for 120fps (44D23E5F.pnach file in my case. I'm using the English translation):

// 60 FPS Kingdom Hearts 2 Final Mix
patch=1,EE,00349E1C,extended,00000000
// Half game speed
patch=1,EE,20349E0C,word,3F000000 // 3F800000

Hmm..
So actually there's not any kind of settings for general games? :c
I don't mind to reach 120 FPS if there's a way to fix the GAP between the monitor refresh rate and the emulator. I think it could cause strange stutterings in any type of game. Couldn't be so?
And... How can I increase the EE cycle to above 50%? It's possible?
Reply
#6
@layrus

is your monitor was plugged in to displayport 1.4? all i heard thats is even better refresh rate than DVI/hdmi
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#7
(10-09-2017, 11:15 PM)LayrusQuinn Wrote: Could the problem come from the monitor refresh rate which is not synchronized at all with PCSX2?
Because I think the stuttering could come from this :/  
PCSX2 doesn't have exclusive fullscreen, so (I didn't test the current vsync setting thoroughly) it's easy to run into problems even when getting fps=Hz. There is a hacky way I know to make it use exclusive fullscreen (which triggers G-Sync, by the way), but it's limited to DX11 hardware rendering. Get "d3d9.dll" and "d3d9.ini" from the file I uploaded in this post of mine: https://forums.pcsx2.net/Thread-Gsdx-3D-...#pid554914

To boot the games in Windows 10 with that, first boot the game, then pause it, open GSdx config, close it, resume the game, and press alt+enter until exclusive fullscreen triggers (easy to know if you have G-Sync. If not, it may be harder to know). Also, forcing vsync in the drivers will make it smoother.

Warning: if you do it a different way, it's easy to make PCSX2 crash. Rename "d3d9.dll" to configure PCSX2 into DX11 renderer if you need it, or when you want to use OpenGL.


(10-09-2017, 11:15 PM)LayrusQuinn Wrote: Hmm..
So actually there's not any kind of settings for general games? :c
I don't mind to reach 120 FPS if there's a way to fix the GAP between the monitor refresh rate and the emulator. I think it could cause strange stutterings in any type of game. Couldn't be so?

Maybe using 60Hz for the rest of games will help. Also, what I said before about exclusive fullscreen.

(10-09-2017, 11:15 PM)LayrusQuinn Wrote: And... How can I increase the EE cycle to above 50%? It's possible?

It's a slider with the default (100%) setting in the middle. Just move it to the right. Are you using a recent PCSX2 build?
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
Reply
#8
(10-10-2017, 01:57 AM)smartstrike Wrote: @layrus

is your monitor was plugged in to displayport 1.4? all i heard thats is even better refresh rate than DVI/hdmi

Nope, neither I knew before your post. I will try this way too! 

(10-10-2017, 08:40 AM)masterotaku Wrote: PCSX2 doesn't have exclusive fullscreen, so (I didn't test the current vsync setting thoroughly) it's easy to run into problems even when getting fps=Hz. There is a hacky way I know to make it use exclusive fullscreen (which triggers G-Sync, by the way), but it's limited to DX11 hardware rendering. Get "d3d9.dll" and "d3d9.ini" from the file I uploaded in this post of mine: https://forums.pcsx2.net/Thread-Gsdx-3D-...#pid554914

To boot the games in Windows 10 with that, first boot the game, then pause it, open GSdx config, close it, resume the game, and press alt+enter until exclusive fullscreen triggers (easy to know if you have G-Sync. If not, it may be harder to know). Also, forcing vsync in the drivers will make it smoother.

Warning: if you do it a different way, it's easy to make PCSX2 crash. Rename "d3d9.dll" to configure PCSX2 into DX11 renderer if you need it, or when you want to use OpenGL.



Maybe using 60Hz for the rest of games will help. Also, what I said before about exclusive fullscreen.


It's a slider with the default (100%) setting in the middle. Just move it to the right. Are you using a recent PCSX2 build?


Uhm.. The last one i've found in the website. 1.4.0. If I turn the slider at max I can't set it above until I reach so much %. 

Should I set my monitor to 60Hz? Maybe with some software tweak I could do this sacrifice :c
Reply
#9
(10-11-2017, 11:18 PM)LayrusQuinn Wrote: Uhm.. The last one i've found in the website. 1.4.0.

https://buildbot.orphis.net/pcsx2/index.php?m=fulllist
Reply




Users browsing this thread: 1 Guest(s)