Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2. All games Lag - PC is fairly powerful
#1
PCSX2. All games Lag - PC is fairly powerful


So I got a new laptop. Lenovo Legion Y520

16 GB RAM

Intel core i7 7700hq @2.8GHz

8 GB video card

ALL games lag. Some less that the others, but most of them lag. I have been trying for like 1-2 months now. No matter what game I throw: DBZ Budokai Tenkaichi 3, Sly Cooper 2, Sly Cooper 3, Silent Hill 2, Star Wars BattleFront 2, God of War 2, Silent Hill Origins...
What bothers me is, most of these games play with a a 60 FPS with around x4 resolution on my brothers laptop, which is at least a generation behind. I tried to do the same settings as his, went to like page 8 of google searches, but nothing worked. Can you please help? I am loosing hope.

Note: Tried versions 1.4 and 1.3. Same issue. Sometimes the fps is good at the menu, but drop in game.
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
First off, know that a fair number of these games are known to be power hungry. Sly Cooper 3 in particular, and my personal experience with Star Wars Battlefront 2 has been meh. That said, some general things to check:

- Windows power plan should be high performance
- GPU (which you didn't specify) driver should be switched off of any "power saving" mode
- If using Geforce Experience, make sure you're plugged in to AC power or just disable battery boost
- Make sure your discrete GPU is being used by PCSX2 in GSdx settings
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#4
check performance plan like pandubz mentioned.

Are you using your integrated gpu vs. the discrete? Is the system Not switching over?
What resolution are you running at?
What does your ee and vu look like when the game is slow?
Does it start off fast and then slow down, or is it slow from the get go?

Reasons I ask -
Performance plan.. can drop a LOT of performance out of your chip... trust me on this, I see a difference of nearly 300 in my stp rating between high performance and default .
GPU - the integrated gpu might be able to handle 2x.. MIGHT.. on most games. If you're using that and trying to rock out 4x.. then that could be a problem
EE and VU - this will give us a starting point to troubleshoot
Start fast and slow down - could be thermal throttling..
amd tr 1950x 
asrock x399 taichi
XFX Radeon rx570
32gb gskill ddr4-3200
Windows 10 Pro
Custom loop water cooled
nzxt 340 case
Reply
#5
(12-19-2017, 09:47 PM)pandubz Wrote: First off, know that a fair number of these games are known to be power hungry. Sly Cooper 3 in particular, and my personal experience with Star Wars Battlefront 2 has been meh. That said, some general things to check:

- Windows power plan should be high performance
- GPU (which you didn't specify) driver should be switched off of any "power saving" mode
- If using Geforce Experience, make sure you're plugged in to AC power or just disable battery boost
- Make sure your discrete GPU is being used by PCSX2 in GSdx settings

I have tried different settings, and managed to get Sly 3 to work on x4 resolution and 60 fps. The problem is, the game is kind of, weird I guess? Resolution and Graphics are amazing, game drops to ~50 fps sometimes, but most of the time it is 60, but the game is not smooth. It is not something that can be desccribed, you have to play it to see what I mean. No luck on SW though.

And yeah I forgot, I have a GTX 1050ti. 

Thanks, any more suggestions?

(12-20-2017, 07:07 AM)scythefwd Wrote: check performance plan like pandubz mentioned.

Are you using your integrated gpu vs. the discrete?  Is the system Not switching over?
What resolution are you running at?
What does your ee and vu look like when the game is slow?
Does it start off fast and then slow down, or is it slow from the get go?

Reasons I ask -
Performance plan.. can drop a LOT of performance out of your chip... trust me on this, I see a difference of nearly 300 in my stp rating between high performance and default .
GPU - the integrated gpu might be able to handle 2x.. MIGHT.. on most games.  If you're using that and trying to rock out 4x.. then that could be a problem
EE and VU - this will give us a starting point to troubleshoot
Start fast and slow down - could be thermal throttling..

(12-19-2017, 09:47 PM)pandubz Wrote: First off, know that a fair number of these games are known to be power hungry. Sly Cooper 3 in particular, and my personal experience with Star Wars Battlefront 2 has been meh. That said, some general things to check:

- Windows power plan should be high performance
- GPU (which you didn't specify) driver should be switched off of any "power saving" mode
- If using Geforce Experience, make sure you're plugged in to AC power or just disable battery boost
- Make sure your discrete GPU is being used by PCSX2 in GSdx settings

I have tried different settings, and managed to get Sly 3 to work on x4 resolution and 60 fps. The problem is, the game is kind of, weird I guess? Resolution and Graphics are amazing, game drops to ~50 fps sometimes, but most of the time it is 60, but the game is not smooth. It is not something that can be desccribed, you have to play it to see what I mean. No luck on SW though.

And yeah I forgot, I have a GTX 1050ti. 

Thanks, any more suggestions?
Reply
#6
Frame drops in Sly games are normal, 3x native will reduce them a bit.
Reply
#7
(01-07-2018, 07:28 PM)MarcellusDrum Wrote: but the game is not smooth. It is not something that can be desccribed, you have to play it to see what I mean. No luck on SW though.

Actually, something does come to mind. Are you playing in full screen, and furthermore are you using OpenGL? I get screen tearing problems if using full screen on OpenGL (but this could also extend to the DX11 renderer, I just haven't encountered this myself). Setting vsync to adaptive fixes my screen tear problems, but this is a 1.5.0 dev build feature. In 1.4.0 and earlier, I think vsync exists as a simple on/off setting, and that may work, but I've personally been using adaptive this entire time.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#8
It just sounds like your GPU is working at its max load. Once a GPU reaches its maximum utilisation, games will start to lag. Start from the native resolution and work your way up. Experiment with each resolution and see which one works the best. You could always check 'Enable 8-bit Textures' in the GSDx settings to reduce the GPU load; it sometimes gives a boost on some games.

As for games not looking smooth, you should enable vsync in the emulation settings, considering you're playing at 60fps. Set it to 'Adaptive' as I find this works the best for anything.

Also do what the other guys mentioned. Changing the power plan to 'High performance' is probably the best thing you could do to get better performance on a laptop. Also, change the GPU's power plan to 'Prefer maximum performance' in the Nvidia Control Panel. Always run on AC, not on the battery.

As a rule of thumb though, games like Ratchet and Clank, Sly Cooper and Jak and Daxter tend to run pretty badly since I believe they share similar engines. I could be wrong though... 
However, If the EE utilisation is around 100% during gameplay then this suggests internal emulation slowdowns, and the only thing you could do after that are use speedhacks or just get a beefier processor Laugh
Intel i5 4460 @ 3.20 GHz,
GTX 1050 Ti,
8GB RAM,
And some other gubbins that make things work.
Reply




Users browsing this thread: 1 Guest(s)