PCSX2 Crash
I am unable to get PCSX2 to start, it instantly crashes. No matter what game I try, it instantly crashes, trying NoDisc crashes as well.
This is a new PC Desktop with completely up to date drivers and such. In addition I have PCSX2 running and fully functioning on 2 other computers. It's this computer in particular I can't seem to get it to run on.

I get two main errors

1. Failed to GetNetAdapter()
McdSlot 0: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\memcards\Mcd001.ps2
McdSlot 1: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\memcards\Mcd002.ps2

2. (IsoFS) Invalid partition descriptor encountered at block 0x10: ''

PC Specs
PCSX2 SVN v1.1.0 5605 (I get the same errors on any version though, I tried 5 of them, r5605, r5604, r5600,r5592 & r5586)
CPU: Intel [email protected] GHz
RAM: GSkill 16 GB DDR3 @ 1866 mhz
Mobo: Asus P8Z77-V Pro
PSU: Thermaltake 700W
SSD: Intel 520 120GB (OS)
HDD: Hitachi 2GB 6GB/s (PCSX2 Run from this drive)
OS: Windows 7 Ultimate SP1 x64
All drivers up to date. Latest Direct X.

I tried deleted all traces of PCSX2 from my computer and used all the stock settings it comes with; no changes other than switching the GPU to make sure it uses the GTX 680 and I still crash and get the same errors. If anyone could please help me, I'd really appreciate it.

I am also using motionjoy & a ps3 controller if that makes a difference.


PCSX2 1.1.0.r5604 - compiled on Mar 31 2013
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 16324 MB
CPU name = Intel® Core™ i7-3770K CPU @ 3.50GHz
Vendor/Model = GenuineIntel (stepping 09)
CPU speed = 3.499 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7f9ae3bf
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding GS: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\plugins\GSdx32-AVX-r5605.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\plugins\LilyPad-r5403.dll
Binding SPU2: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\plugins\SPU2-X-r5559.dll
Binding CDVD: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\plugins\cdvdGigaherz-r5403.dll
Binding USB: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\plugins\USBnull-r5484.dll
Binding FW: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\plugins\FWnull-r5484.dll
Binding DEV9: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\plugins\DEV9ghzdrk-r5602.dll
Plugins loaded successfully.

(GameDB) 9644 games on record (loaded in 132ms)
(CdvdSource) HotSwapping CDVD source types from Iso to NoDisc.
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
NVIDIA GeForce GTX 680 (
Opening CDVD
Opening USB
Opening FW
Opening DEV9
Failed to GetNetAdapter()
McdSlot 0: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\memcards\Mcd001.ps2
McdSlot 1: D:\Games\Emulators\PS2\pcsx2-5605-windows-x86\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.00(14/06/2004) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(IsoFS) Invalid partition descriptor encountered at block 0x10: ''

Sponsored links

Partition descriptor? Did you modify the ISO? And Failed to GetNetAdapter, doesn't seem right. Are you trying to use the internet?
Specs: Intel Pentium P5 @ 60 Mhz, 1 Gigabyte HDD, OS: DOS
1) That particular log ran the NoDisc option however, ALL my isos give me the same errors. I even reripped a few of my games from their disks to try it out, still the same results.

2)I'm not using anything that would make PCSX2 attempt to get internet access. I'm using PCSX2 with whatever it comes with from the pre-compiled builds (+My bios of course).

I've been using PCSX2 on several computers for a while now but I've never seen these 2 errors before. This is a completely new computer which is why I'm surprised it's having these problems.
select dev9 null plugin instead of DEV9ghzdrk
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Thank you very much, I no longer get the errors and I can sucessfully boot and play.

I really appreciate it.

Users browsing this thread: 1 Guest(s)