PCSX2 Freezes When I Plug in Dualshock4
This is probably my fourth or fifth attempt to get into emulating, and each time I run into issues that I can not seem to find solutions to. This time around I can get games to launch just fine, but found it was very finnicky to get it to work with mouse and keyboard, so today I decided to try and use my Dualshock 4 controller, but everytime I plug it into my PC, or whenever I go to try and map controls, PCSX2 stops responding. I'm also unable to open "Set up USB game controller" on windows 10. I have seen that lots of people have issues with PCSX2 freezing on them, but it seems to be in game, and only for a moment, whereas I can't even get into the config tab before the entire program stops responding.

I'd really like some help with this issue as bluetooth isn't an option for me, and I would really love to be able to play some of my childhood favorites without paying an arm and a leg, and praying I get a working copy.

Sponsored links

ds4windows, disable ds4 thing whatever the option is.
Have you tried using DS4Windows?
Windows 11 64 bit OS
Intel Core i7-10700
Geforce RTX 2060 6GB
you shouldn't need to map controls with an xinput wrapper. do what catlin suggested above (ds4windows) or use steam. That will be the fastest and simplest way
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)