Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Hates SCPToolkit?
#1
I tried asking this same problem over at the scptoolkit thread, but the dev didnt respond, so im hoping anyone here can help

I depend on scptoolkit to let me play ps2 games with a ds4 controller (because I like how it feels better than the ds3 controller), but lately, when I updated to windows 10 creators update, and even before that, pcsx2 absolutely Refused/Refuses to work with SCPToolkit (with both the latest stable and beta/git pcsx2 build); im sure some people here use scptoolkit with pcsx2 (if they still do), so tell me, has scptoolkit been broken with later versions of windows, or is there a way to make it work

TL;DR Can't use SCPToolkit with pcsx2 (any version), any way to fix, or am I S.O.L, or is there an alt to use; I tried ds4windows, but of course I had problems


Attached Files Thumbnail(s)
   
Now go help me flame these zombies to canada
Reply

Sponsored links

#2
http://forums.pcsx2.net/Thread-FireShock...ontrollers

Made by the same person -- Nefarius -- so thank that person.... but able to be updated since microsoft did things to updating SCPtoolkit (well at least if it still wants to support 64bit win7). This is what you should use if your on Windows 10 and having an issue with SCPtoolkit due to Windows doing silly things.
Reply
#3
I'd suggest using DS4Windows.
[Image: iq2O9Ya.jpg]
Reply
#4
(08-24-2017, 01:02 AM)FaithLV Wrote: I'd suggest using DS4Windows.

The OP said that he tried DS4Windows and had issues.
Reply
#5
maybe ill use fireshock, but question, would this fireshock also work on the dolphin emulator, and games on steam? Also saw that it doesn't have bluetooth support, and I kinda like having bluetooth support, but scptoolkit apparently s***s the bed in that regard

the only emulators I use are pcsx2 and dolphin
Now go help me flame these zombies to canada
Reply
#6
you will need https://github.com/nefarius/ViGEm to have it work as an X-input device (needed for some steam games that only support the xbox controller), but looking at the support this may not be working with the latest version (so not sure)

As far as emulation goes both pcsx2 and dolphin work with pretty much any input api so your covered there.
Reply
#7
well, I installed the ViGEm drivers; all thats left is to figure out how to make fireshock with with a git build of pcsx2; minaly because when I installed pcsx2 1.4.0, when I went to install fireshock it showed an option to install some modifications to it; if I could have it do the same to a git buld, or at the very least, figure out which files it installs to pcsx2 that enables said mods, I could make it work

anyone know what files fireshock installs to pcsx2 that enables the mods?
Now go help me flame these zombies to canada
Reply
#8
It probably is the lilypad.dll if your talking about pressure sensitivity on the buttons. You should be able to just copy it over from your 1.4.0 instillation.
Reply
#9
so fireshock modifies the current lilypad.dll from the pcsx2 1.4.0 install, or it overwrites it with its own lilypad.dll like scptoolkit does

if thats the case, then problem, because the so called fireshock modifications dont show; should I use an older version of fireshock/ViGem, or should I just let pcsx2 rest in peace forever?
Now go help me flame these zombies to canada
Reply
#10
to make it short, check my latest post on the fireshock thread here, and that is how far im at

I need to figure out how to make it recognizable by dolphin (that emulator takes scptoolkit) and get rumble support working; otherwise, im all set

again, help would and will be welcome please
Now go help me flame these zombies to canada
Reply




Users browsing this thread: 1 Guest(s)