Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Not Running Gran Turismo 4
#1
My copy of Gran Turismo 4 is not working with the PCSX2 emulator. I've got two hard copies of the game, both of which work on the PS2 console, but none of which really seem to work on the emulator. Both discs are clean. It will make it through the startup screen, display "PLAYSTATION 2", then display the legal warnings, then blackscreen. I've gotten the PCSX2 emulator to work with other PS2 games with no problems at all, which is why I can't seem to figure out what's wrong with getting this game to work.

___

Computer specs

Acer Aspire V3-771G-9456
Windows 8
Intel Core i7 3632QM (2.20GHz)
6GB DDR3 RAM
2GB Nvidia 640M (v.331.84)

___

PCSX2 Settings

[Image: rO77pEp.png]

___

Runs other games perfectly, full framerate, etc. I'll play with settings and if I find a fix I'll make sure to post it here, but if there's some sort of patch or plugin I need to play this game I'll need your guys' help with that. I'm sure I'm missing something very simple. Thanks a lot!
Reply

Sponsored links

#2
Why are you using DX9?

Change renderer to "Direct3d 11 Hardware" and try.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
have you tried pressing X?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
(12-08-2013, 02:28 AM)refraction Wrote: have you tried pressing X?

Yep, tried to skip the opening sequence with all buttons, didn't work.

(12-08-2013, 02:05 AM)Blyss Sarania Wrote: Why are you using DX9?

Change renderer to "Direct3d 11 Hardware" and try.

Because that's what I used when I played my last game on it (FFX). Changed it to DX11, no luck.
Reply
#5
Which version of PCSX2 are you using?

Try the latest one from here:

http://buildbot.orphis.net/pcsx2/

This game is known to be playable, so maybe a fresh PCSX2 will do it.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#6
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • If you are playing them from ISO or DVD.

Thank You.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(12-08-2013, 03:18 AM)refraction Wrote: [*] If you are playing them from ISO or DVD.

That's a pretty important one that OP didn't mention, actually.

If you are using a disc, you definitely need to make an ISO of it. It works way better that way.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
(12-08-2013, 03:18 AM)refraction Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • If you are playing them from ISO or DVD.

Thank You.

Hardware

Windows 8
Intel Core i7 3632QM (2.20GHz)
6GB DDR3 RAM
2GB Nvidia 640M (Driver v.331.84)

PCSX2 Version

1.1.0.5766

Non-Default Settings

[Image: kwyTaNO.png]

Playing from

DVD
Reply
#9
(12-08-2013, 03:59 AM)CCXR Wrote: Playing from

DVD

I bet that's your problem.

Go get imgburn and use it to make an ISO of your disc, then run from that.

Also beware of this issue with your driver:

http://forums.pcsx2.net/Thread-Graphics-...ia-drivers
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#10
(12-08-2013, 04:03 AM)Blyss Sarania Wrote: I bet that's your problem.

Go get imgburn and use it to make an ISO of your disc, then run from that.

Also beware of this issue with your driver:

http://forums.pcsx2.net/Thread-Graphics-...ia-drivers

Works from .iso. Thanks!
Reply




Users browsing this thread: 1 Guest(s)