Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Random Frame Drops
#1
So I've been trying to get pcsx2 to play metal gear 2 and 3 and devil may cry 3 for the most part. But it's been running like it's in slow motion and the speed drops in the opening sequences for mgs2 and 3.
It's been bugging me and I've been tinkering around with the settings for a while but I can't seem to get it right.

Can anyone help me?

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
(09-30-2020, 06:20 PM)jesalvein Wrote: Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):

here's the log:
also note, i saved the game during the part where the frames suddenly dropped which was slightly after i had fixed the ""initial"" frame drop which was at the start of the opening sequence

Code:
Loading language translation databases for 'English (Philippines)' [en_PH]
    pcsx2_Main not found -- translation dictionary may be incomplete.
    pcsx2_Iconized not found -- translation dictionary may be incomplete.
SetLanguage: Requested translation is not implemented yet.
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
    Operating System =  Microsoft Windows 10  (build 19041), 64-bit
    Physical RAM     =  8072 MB
    CPU name         =  Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
    Vendor/Model     =  GenuineIntel (stepping 09)
    CPU speed        =  2.495 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7ffafbbf
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Loading language translation databases for 'English (Philippines)' [en_PH]
    pcsx2_Main not found -- translation dictionary may be incomplete.
    pcsx2_Iconized not found -- translation dictionary may be incomplete.
SetLanguage: Requested translation is not implemented yet.
Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\gsdx32-avx2.dll
Windows 10.0.19041
    Binding  PAD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\lilypad.dll
    Binding SPU2: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\spu2-x.dll
    Binding CDVD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\cdvdGigaherz.dll
    Binding  USB: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\USBnull.dll
    Binding   FW: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\FWnull.dll
(GameDB) 9693 games on record (loaded in 262ms)
    Binding DEV9: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.

    HotSwapping to new ISO src image!
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 10.0.19041
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: C:\Program Files (x86)\PCSX2 1.4.0\Games\Metal Gear Solid 2 - Substance (Europe) (En,Fr,De,Es,It).iso
    Image type  = DVD
isoFile: searching for layer1...
isoFile: loaded second layer from settings cache, sector=0x00119510
* CDVD Disk Open: DVD, Double layer:
* * Track 1: Data (Mode 1) (3082912 sectors)
    Opening USB
    Opening FW
    Opening DEV9
Current Renderer: Direct3D9 (Hardware mode)
NVIDIA GeForce GTX 1050 (27.21.14.5655)
McdSlot 0 [File]: C:\Users\aesgu\OneDrive\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\aesgu\OneDrive\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: Japan   v01.00(17/01/2000)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.17, ctm:393Mhz, cpuclk:295Mhz )

PlayStation 2 ======== Hard reset boot
ROMGEN=2000-0117, IOP info (CPUID=1f, CACH_CONFIG=ffffffff, 2MB, IOP mode)
<20000117-050310,ROMconf,:11232>
# Total accessable memory size: 32 MB (B:2:8:0)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Dec 10 1999 17:48:37
  CPUID=2e20, BoardID=0, ROMGEN=2000-0117, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_820.09;1
(SYSTEM.CNF) Software version = 1.02
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SLES_820.09;1) Game CRC = 0x093E7D52, EntryPoint = 0x00100010
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_820.09;1
(SYSTEM.CNF) Software version = 1.02
(SYSTEM.CNF) Disc region type = PAL

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLES_820.09;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLES_820.09;1
1 00100000 00080fec .........
2 00181000 000346c0 ....
Loaded, cdrom0:¥SLES_820.09;1
start address 0x100010
gp address 00000000
# Loader 'cdrom0:¥SLES_820.09;1':pc=00100010
Get Reboot Request From EE

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥MODULES¥PLD.IRX;1 args 9 arg 00c00000
loadmodule: id 25, ret 1
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
> Selected savestate slot 0
Loading savestate from slot 0...
    filename: C:\Users\aesgu\OneDrive\Documents\PCSX2\sstates\SLES-82009 (093E7D52).00.p2s
EE/iR5900-32 Recompiler Reset
    Loading GS
    Loading PAD
    Loading SPU2
MTVU speedhack is enabled, saved states may not be stable
> Selected savestate slot 1
    Backing up existing state in slot 1.
Saving savestate to slot 1...
    filename: C:\Users\aesgu\OneDrive\Documents\PCSX2\sstates\SLES-82009 (093E7D52).01.p2s
MTVU speedhack is enabled, saved states may not be stable
    Saving GS
    Saving PAD
    Saving SPU2
(gzipThread) Data saved to disk without error.
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
#4
1.4 is unsupported, update to 1.6.
#5
(09-30-2020, 08:00 PM)CK1 Wrote: 1.4 is unsupported, update to 1.6.

I originally got 1.6 but the problems originally occurred with 1.6. I switched to an older version to see if it'd help but it obviously didn't. Also all the videos I looked at to try and fix this problem were all in 1.4.
#6
(09-30-2020, 05:34 PM)bom.piou Wrote: So I've been trying to get pcsx2 to play metal gear 2 and 3 and devil may cry 3 for the most part. But it's been running like it's in slow motion and the speed drops in the opening sequences for mgs2 and 3.
It's been bugging me and I've been tinkering around with the settings for a while but I can't seem to get it right.

Can anyone help me?

not so sure but i think large framebuffer might help with the opening sequences
#7
(10-01-2020, 12:30 PM)scalerize Wrote: not so sure but i think large framebuffer might help with the opening sequences

how do i do a large framebuffer??
#8
Untick it in gsdx config panel.
Enabling it will probably worsen your problems
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#9
(10-02-2020, 03:57 PM)jesalvein Wrote: Untick it in gsdx config panel.
Enabling it will probably worsen your problems

Is there something else I can do to try and better the problem? I can reinstall 1.6.0 version and look at the plugin options for video there since there are more options for it
#10
do you own another PS2 console ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)