Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Running at exactly 50%
#1
Hey everybody, I'm new to using PCSX2 so I just got it up and running yesterday because I felt like playing some Sly 2. I played for like an hour last night and it was running well at 100% speed/60fps (although it would occasionally drop to 65/75%, not sure what that was about). Anyway, when I booted it up this morning, the intro to the game was running at 100% speed but as soon as I got into the actual game it dropped to exactly 50% speed/30ish fps. I have a gaming laptop so I know processing power/graphics isn't the issue, especially since I played it mostly flawlessly yesterday.

I've already tried turning off vsync in my graphics card's control panel because I read in a forum that could cause the problem, is there a way to turn off vsync in PSCX2 as well?

Anything helps, so thanks in advance!


(P.S.)
If there is a way to get it unstuck from 50% speed, what's my best option to keep it from occasionally dropping to 75% like it was for me yesterday?
Thanks!
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#3
Also, does it say "Slowmo" in the title bar of the emulator?
Reply
#4
(03-12-2018, 07:46 PM)CK1 Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Hardware specs: 
7th Gen Intel® Core™ i5-7300HQ mobile processor (quad-core)
8GB system memory
256GB solid state drive
NVIDIA GeForce GTX 1050 Ti graphics

PCSX2 Version 1.4.0
Only non default settings I know of are upping the resolution to 1920x1080 and checking the box that said was recommended for 3 or more cores. However I've tried going back to default settings to help fix my problem and it did not.

The only game I'm trying to play is Sly Cooper 2, and it's from an ISO, was running perfect yesterday

(03-12-2018, 07:46 PM)CK1 Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

No it does not say "slomo". I tried the shift-tab and it made it go into slomo so I put it back to normal
Reply
#5
OK, try the latest dev build here and make sure you're using the OpenGL renderer: https://buildbot.orphis.net/pcsx2/
Reply
#6
Could it be a thermal throttling issue ?
Did you set your power plan to high performance ?
Are you sure your laptop isn't running on batteries ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(03-12-2018, 08:54 PM)jesalvein Wrote: Could it be a thermal throttling issue ?
Did you set your power plan to high performance ?
Are you sure your laptop isn't running on batteries ?

Okay, kind of feel like an idiot now...
I was playing off of my laptop's battery life, once I plugged it in the issue of it being stuck at 50% speed was fixed, thank you!

However, I'm still getting random fps drops to around 70% speed, any tips for that?

Thanks
Reply
#8
Sly 2 does that even on high end desktops, so I don't think there's much you can do about that, sorry!
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
(03-12-2018, 09:45 PM)refraction Wrote: Sly 2 does that even on high end desktops, so I don't think there's much you can do about that, sorry!

Oh, lame haha

Thanks anyway!
Reply
#10
Just as a FYI, the FPS drop is most likely due to the Battery Boost feature in GeForce Experience. If you disable that, or just raise the FPS limiter on it, that will do the trick.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply




Users browsing this thread: 1 Guest(s)