Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 Won't Open, Windows 8.1
I was able to use PCSX2 until 1.2.1. However after I downloaded 1.4.0 release, it won't open at all. Is there any problem related to my computer? No window shows up, and task manager says it opened and closed immediately.

By the way I am using Windows 8.1, with all VCRedist installed, both x86 and x64.

Sponsored links

First you need spec like CPU, GPU, RAM and HDD
Oh yeah, my spec is i7-4700HQ, 8GB DDR3L, NVIDIA GeForce GTX 860M, and 1TB 5400RPM.
full installer or binary version ?
try using this vc++ installer
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Did you check your PCSX2 and My Documents/PCSX2 folders to see if all traces of 1.2.1 are deleted? There might be a conflict if you installed over it.
It's... not... there. There is no PCSX2 folder in Documents, only PCSX2 1.4.0, where binary is located.

I tried both binary and installer.
Repaired all VCRedist. No good.
Event Viewer says this in error:

Faulting application name: pcsx2.exe, version:, time stamp: 0x568bfd0e
Faulting module name: ucrtbase.DLL, version: 10.0.10586.9, time stamp: 0x5642c5f8
Exception code: 0xc0000409
Fault offset: 0x00083472
Faulting process id: 0x430
Faulting application start time: 0x01d17a84c2f5053b
Faulting application path: C:\Program Files (x86)\PCSX2 1.4.0\pcsx2.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ucrtbase.DLL
Report Id: 00b86032-e678-11e5-82e0-28b2bd93ab42
Faulting package full name:
Faulting package-relative application ID:
Quote:Faulting module name: ucrtbase.DLL,
it's part of the vc++ runtimes
did you run as admin the installer i linked you ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Nope, even your installer is still no good, jesalvein.

Users browsing this thread: 1 Guest(s)