PCSX2 builds on openSUSE
After downloaded the pcsx2 1.2.2 for linux, under the main directory I tried
ldd pcsx2
and $zypper wp The_Package_listed_Above.so.* to search dependencies and figured out what I needed is below:
zypper install libfreetype6-32bit libgtk-2_0-0-32bit libgthread-2_0-0-32bit libaio1-32bit

Then I needed to in order download the 32bit version of libwx_baseu-2_8-0-wxcontainer, libwx_gtk2u_core-2_8-0-wxcontainer and libwx_gtk2u_adv-2_8-0-wxcontainer from official web http://software.opensuse.org/.

I run the program with
and succeeded, but GS, PAD and SPU2 couldn't be chosen. So I again searched the dependencies listed from Pcsx2 official.

GS needs Nvidia Cg Toolkit, I downloaded the 32 bit ver from https://developer.nvidia.com/cg-toolkit-download and installed it.

Other installed with:
zypper install libbz2-1-32bit Mesa-libEGL1-32bit libSDL-1_2-0-32bit libSoundTouch0-32bit libportaudio2-32bit

libglew openSUSE official just has 1.9 ver, so I downloaded the Fedora 32bit ver from http://pkgs.org/fedora-rawhide/fedora-i3...6.rpm.html

Everything works fine except sound XD

/* 20140405 */
Now sound works. I wondered which are the missing packages, but install them should help:
zypper install alsa-plugins-pulse-32bit libpulse0-32bit alsa-plugins-32bit

Also download and install alsa 32bit ver from http://software.opensuse.org/package/alsa
Then sound works and no alsa error is reported.

Thank you gregory from #2.

Sponsored links

you probably missing an audio plugin. Search pulse and alsa package.
I know this might sound a little silly, but is the null plug-in selected? Also, have you tried tinkering with the settings.

I've had this problem a few times before. In one case it was as Gregory suggests -- I was missing some packages (lib32-libpulse in particular), however there were some times where the pluggin was set to null, or some of the settings for the pluggin were wrong.
i7 4930k @4.3, 4x4 GB RAM @2133 (15-15-15-27, quad channel), EVGA 570 @stock, Arch 64b.
(04-04-2014, 09:19 AM)gregory Wrote: you probably missing an audio plugin. Search pulse and alsa package.

Everything works fine now, post has updated. Thank you for the tip Biggrin

Users browsing this thread: 1 Guest(s)