PCSX2 crashes in Samurai Warriors:XL after update
#1
Hi, new user here.
Emulator started to crush in Samurai Warriorrs: Xtreme Legends after update. Last version i used(v1.7.4360+ made in 9th of april, but before the update that broke all the savestates) worked just fine. I postponed the update a little and did it maybe an hour ago(maybe even less). So now i have v1.7.4397 and the SW:XL started to go blackscreen and crush right after selecting any map and watching through a pre-battle text. What should i do?

Sould i pin the crash txt\dmp files?
Reply

Sponsored links

#2
Please post emulog when problem occurs. Crash/dump may be of use for developers.
Reply
#3
the crash txt/dmp would be very useful, thanks.
[Image: ref-sig-anim.gif]

Reply
#4
I did some testing and found out that game crashes both after enabling mipmapping anything other that default or making internal resolution anything higher than native.

Mipmapping problem is a bit more severe, i think, because it crashes the emulator every time in the most random of places without fail, especially if you try to play the any stage itself.

But for some reason, the internal resolution part is not this severe: it crashed the emulator in the second main menu after trying to select anything other than was already highlighted, BUT if you already started playing the stage in native resolution, but change it while playing - the emulator handles it fine. 

For this reason i'll leave two crash logs\dumps for precaution. First one was is when i changed mipmapping option during gameplay(which immediately crashed emulator) after successfully changing the internal resolution. 
.7z   crash_dump1.7z (Size: 174,1 KB / Downloads: 45)

The second one is when i tried to disable mipmapping option and started play around with menu in not-native internal resolution.
.7z   crash_dump2.7z (Size: 152,69 KB / Downloads: 59)

Sadly, i wasn't able to find emulog anywhere. Not in the emulator directory, not in the my documents, not in AppData folder and not even after making a full search of the disc. Maybe there's a special option i missed that allows that log to appear?..

I hope that this is this game problem only, because i didn't tried to play any other game after an update... But if anything else happens - i'll let you know.
Reply
#5
So the crash only happens when you mess about with the mipmapping option? is there any reason you aren't leaving it on auto?
[Image: ref-sig-anim.gif]

Reply
#6
(04-18-2023, 10:18 PM)refraction Wrote: So the crash only happens when you mess about with the mipmapping option? is there any reason you aren't leaving it on auto?

Nah, not exactly for this game. Had a few games in the past(and, if i'm remember correctly, some of which that are still in my "library") that couldn't work properly without mipmapping, but don't remember which now, because it was long ago and after i enabled mipmapping i never took it off. Still, kinda strange for a problem to occur for something that worked rather fine for a long time.

Also, i did said that emulator crushes sometimes just because of non-native internal resolution, which is also strange and locking me into playing on "lowest settings"(i didn't fully test the extent of what is "allowed" in higher res in this game, but menus are definitely aren't one of those "allowed" things)

I guess what i'm concerned about the most is if something like this can happen in the other games too, but i don't exactly see any other people complaining, so maybe i just panicking. Thank you for your time and help! :3
Reply




Users browsing this thread: 1 Guest(s)